Unable to select a group, then the group disapears, (seems to get deleted)

I have a problem selecting grouped items in a model. I have tried ctl+A and still not selected.
I then change to another scene and then return to the previous scene the grouped items have been deleted from the model.

Anyone else had this problem? Am I missing something?

We can only guess.
Can you attach a model that displays this behavior.

I could, but the file size is limited to 1 MB the file is 5+ GB.
I can try a link to Dropbox.

Try this link the previous link is the result after changing scenes.

No saved layer set in a scene may let things look like items with turned off layers have disappear. In fact they may very well be just invisible.


I don’t think so, the layers are all on for the scene that I am not able to select certain items that are in a group. It also appears that after I save the file the next time I open it the items that were not selectable are now deleted.

The link to the file in the previous post in no longer valid

Did you get the full file in the second link?

Layer “civils” is not on in your second image.

The civils layer doesn’t appear to be the problem. I think it is something to do with the grouping. The green bin at the top and the top structure are not able to be selected. I have no idea why this is.

Both links are dead, but I’m going to bed anyway. Others may find the files useful.


Is the bounding box Red when you try to select it?

Thanks for the demo. I never tried from the list of groups. I’ll try it when I’m back at the PC
Thank you.

What you don’t see in the demo. … he is selcting the first hidden group (in the Outliner panel) then holding the SHIFT key whilst clicking the last hidden group. (This is normal MS Windows workflow for selecting a contiguous set of sequentially listed objects.)
Afterward you right-click the selected set in the list to bring up the contextual menu and choose your function to perform (in this case “Unhide”.) The command is then applied to all items in the chosen set.

This is a good lesson for you in NOT using the old “Hide” / “Unhide” per object feature to control visibility.

It is recommended that instead you use layers to control visibility.

You’ll need to go to the first scene, unhide everything, and update that scene. Repeat for all scenes.
Save the model.
Then decide how to organize your layers for visibility control, making new layers if needed.
Move groups to the appropriate layers if you must.
Then go through the scenes again setting which layers are visible and hidden, updating the scenes as you go.
Lastly save the model.

Thanks for all the help, much appreciated.

1 Like

Also, by turning on “hidden geometry” you can often get a glimpse of items that exist but are currently hidden. It’s possible to select them in their ghosted way and “unhide”. As Dan says, using layers to control visibility is a more robust/reliable method than hiding objects and saving in a scene.

1 Like

This was not an issue with ver 2018. Quite clearly it’s a bug, Unhide all - should Unhide all. Shouldn’t need to use the outliner in this situation. Very time consuming. I find that you are not able to select all in the outliner and unhide?

The ‘Hide’ function hasn’t changed from 2018 to 2019. You can only ‘Unhide all’ in the current context. Which is why you shouldn’t use it for multiple scenes etc… as you have found hidden things become hidden and can’t be unhidden using scenes or layers.