Unable to remove noise from the final render in V ray for skp

I tried changing various settings but i am unable to get the final render without noise.
I am attaching the skp file link, the view that i rendered and the settings in the asset editor.
Please tell what i am doing wrong. Its urgent!

Have you enabled the denoiser?

yes I did

Is it enabled in the frame buffer?


Turn the opacity to 100% - is that any better?

no change

does it have anything to do with bucket size?

ok, so it looks like you have too many lights and many that are too bright which is overexposing everything.
The rays of light are so intense that the rest of your settings can’t handle that.
As a note, the default material white walls in SketchUp will reflect 100% of that energy back into the model, making this worse. You want to be using a light grey color for “white”.

  1. You don’t need 5 dome lights - 1 Sky is plenty :slight_smile:
  2. The sunlight and 5x domes are all set to 5000 - a value of 1 is considered daylight.

Delete your domes and set the sun to 1

Run Lightgen and pick a setup that looks good to begin with

Then start renabling the rectangle and spotlights lights again if you still need them

The denoiser works after the render has finished. Your screenshot shows a render in progress.
If the denoiser is on, dragging the quality slider all the way to the right just increases render time without any visible improvement. You can leave quality at Medium.

I have a vague remembrance that some glass material settings could have an effect. Cannot test as my V-ray is dysfunctional since September…

The denoiser simply can’t keep up even if it runs - camera exposure is currently set to 1 and the post process exposure is set to -5.
You could clamp some values that are causing the fireflies, but the reason for their existence is the unnatural lighting setup.

I would actually use the progressive renderer with the denoiser set to update often - that way you can simply stop the renderer if it looks good enough.

If you are going to be saving jpegs/pngs from here too - don’t forget to add the filmic tonemapper as the top layer also.


Than you so much for explaining me in detail. I will make all the corrections and try again now. But a big thanks to you!

ohh alright. I am a beginer at this and wasnt aware of it. Thank you so much.

This looks so good. Thank you. Is that possible if you can share the asset editor settings here for this render. I want to know how the lighting perfect bright from the window. I also want to know the exposure value.

You may be interested in our free course on Rendering Photo-Realistic Interiors over at SketchUp Campus - V-Ray for SketchUp Interiors Cheers.


Probably easier to follow the steps to get it to a similar position.

  1. Delete all the dome lights and right click sunlight and choose “reset”
  2. Go to the render settings screen and reset them all to default using the button in the bottom right (exposure will change to 14.something)
    3.Turn on denoiser, set it to often and choose one of the options - I like the intel openimage one.
  3. Open framebuffer and reset/delete the exposure layer.
  4. Add the filmic tonemapper layer
    6.Run V-Ray lightgen on the interior setting and let it generate some options - I chose the 6th one. Double click it to apply. This will automatically set the exposure for you.
    7.Run an interactive render and turn on the lights one by one checking they are having a postive effect- rectangle light#6 t in particular immediately makes things too bright, keep it turned off or decrease the brightness to balance it better.
    8.In the framebuffer, adjust the exposure to your taste and maybe even bump the saturation down a little with a saturation adjustment layer placed below the filmic tonemapper.
    9.Make sure the denoiser layer is active, I personally drop the opacity down a little to keep a small amount of noise.

I ended up with something like this


I will check this out!

I will do so. And once again thank you for putting so much effort in explaing this to such detail. :smiley:

1 Like

You’re welcome . Let us know how you get on!