Unable to open sketchup files in Windows 11 for 2 days

i’m unable to open my sketchup files in Windows 11. I’m working on same laptop since 6 months, but now suddenly the files are getting closed in few seconds.
im facing this problem since 2 days?
I tried by restarting the laptop, but no use.

Hope, i will get a good response and solution from this community.


Your forum profile indicates you are using SketchUp Free Plan which is the web based version. Is that correct? If so, what browser are you using? Have you tried a different browser?

So in fact you are able to open the files, but then Sketchup closes after a few seconds?
Are you getting a “Bug Splat”?

There was an optional Windows update released last week and I’ve heard a few people (not Sketchup related) have problems after installation.

Could it be this? Did you do a windows update recently?

“Operating System” : 1-329-111 suggests its SketchUp Studio…

That might be. Then it isn’t the answer to the profile question of what operating system.

1 Like

Do you use a Space Mouse? When I have seen crashing after opening any file on Windows 11, it was a problem with the 3DX drivers.

Latest driver is a month old: 3DxWare 10 Archives - 3Dconnexion NL

thankyou Colin,
I’ll try it definitely.

Yeah its Sketchup studio, in which i’m working.

No, it just opens and closes immediately.

no i haven’t updated.