Existing sketchup files won't open?


#1

When I try and open my saved sketchup files the file appears to open but then shows a blank page with none of the saved drawing there. Also none of the tools work-they move around the screen when selected but wont function. Sketchup has been working fine since I purchased it in July and I open these files and work with them weekly, this is a new situation? Any ideas?


#2

In SketchUp, go to Window>Preferences>OpenGL and untick Use Fast Feedback. Any improvement?


#3

Dave your a saint !! Fixed it. What was that about ?? What a relief, I thought I may have lost weeks of work !!

Thanks very much-Nick


#4

Thank you.

I expect you, or more properly, your computer, was the victim of an automatic update pushed by Microsoft which broke the Intel graphics drivers. This isn’t an unusual occurrence. Unfortunately Intel Graphics are well-known to be inadequate in their handling of OpenGL and the driver updates often tend to make things worse instead of better. Also unfortunately, Microsoft pushes automatic updates which makes keeping on top of this a bit like herding cats. You probably won’t notice any real issues with Fast Feedback being disabled but it may be that after the next update from Microsoft you can turn it back on. Or maybe not.

If you have an opportunity to upgrade or replace your computer at some point, I would suggest getting something with a reasonably up-to-date Nvidia Geforce graphics card. We don’t see issues from folks who have them.


#5

I’m not a Windows expert, but this whole adventure with bad driver updates from Microsoft raises the question: is there a way to lock drivers so that an automatic update can’t overwrite or reset them? Maybe some trick with file permissions or Registry settings? It would seem that if you have a stable configuration, the last thing you want is the OS destabilizing it behind your back!


#6

You can adjust auto update to only tell you what updates are available and then choose which to install. I went for over a year without updating one of my Nvidia cards because it had caused problems, then I eventually turned it back on once it was working.


#7

That would be a good thing if it could be done.

I’m not sure if auto-updates can be prevented in non Windows 10 Pro versions. I have Pro on my three PCs and have it set up so I can determine when and if updates get installed.

I guess since I also have Nvidia graphics cards in all of my computers, I’ve never had any reason to care about what Microsoft does to the Intel Graphics drivers that might get installed.


#8

Do you have driver-by-driver granularity over this setting, or is it all-or-nothing? That is, can you lock out just one driver for “ask me” and let them do the rest automatically, or does this mean that for each update you must look at what was included and manually reject updates for your graphics driver?

Note: I’m pushing this issue in an effort to help other readers find the best solution for their specific situation. Many non-techies won’t like having to do the manual process each time.


#9

I have it set to download but tell me before it installs. Then I open the list and just check what it is doing, I can tick all and untick one. then go for it.
It doesn’t take a lot of effort and it stops it doing it whenever it wants, which can mean it restarts while you are cooking dinner therefore deleting any work you have done on any files you have left open.