Unable to import models from 3D warehouse

Hi.

I am new to sketchup. Last 30 days it worked perfectly, but today suddenly i am not able to import furniture to my architectural project. I have tried everything - restart, unistallation and reinstallation etc, but nothing works. When importing, then it downloads the item, but then crashes.

I tried to purge unused components, but even then sketchup crashed. Is there anything else i can do? Any suggestions?

How big is your SketchUp model file? When it crashes are you getting Bug Splats? Are you sending them in with some information that identifies them as coming from you?

Maybe you could share the .skp file so we can have a look and see what is going on.

Thank you!

Answers to your questions:
-It is 140,7MB.
-No, I’m not getting Bug Splats.

I quite don’t get the last question “are you sending them in with some info…”. What do you mean by that? :slight_smile:

Link to the file is here: https://drive.google.com/file/d/1A8Vin1dqv-qxgo-ri9Ifek-1TtxLdkWy/view?usp=sharing

If SketchUp was crashing with Bug Splats you would be asked to send in the report and could add your name and/or e-mail address. If you aren’t getting splats, you would have the option to send in a report.

I get an error when trying to follow your link.

I think you need to make the link public shared. I get a screen saying I don’t have access.

1 Like

Is it possible now: https://drive.google.com/file/d/1A8Vin1dqv-qxgo-ri9Ifek-1TtxLdkWy/view?usp=sharing

If not, then I uploaded it here as well: https://we.tl/t-R2aPtLDL2E

The Google Drive link worked this time. I was able to cleanup and purge the file without any problem.

Screenshot - 1_8_2021 , 10_46_47 AM

Screenshot - 1_8_2021 , 10_47_56 AM

This reduced the file size by over 65%.

By the way, you’ve got a lot of reversed faces and ungrouped geometry in your model. You should fix those. I’ll upload the cleaned version shortly. It’s still too large to upload directly.

Looks like you are using a lot of content from the 3D Warehouse and much of it looks like it could stand to be cleaned before being added to your project. It’s always a good idea to download components from the 3DWH to a separate file, clean them up and then add them to your project.

1 Like

Here’s the link.

I expect your computer just isn’t up to the task of handling your huge file. Purging more regularly would help.

1 Like

I cannot thank you enough! Spent almost half of my day to find out, what the hell is going on there :'D

Still funny that i wasn’t able to purge the file. Now i am going to do it once in a while just in case.

Thank you for the recommendations about reversed faces and ungrouped geometry - will read more about it right away! Also I didn’t know about the need of cleaning the content, but will do it in the future and saving components to a separate files :slight_smile:

Thank you so very much!!!

I got your model. It is already quite “heavy”, Model Info->statistics shows almost a million edges. About 2/3 of those come from just four things you no doubt downloaded from the 3D Warehouse:

  • Group#1348 (curtains) contains 196,934 edges
  • Group#990 (grill, sink, and counter) contains 142,175 edges
  • Vase_Flowers_22 contains 115,325 edges
  • Extemporare standard table… contains 104,003 edges

This is why we always advise that you download from the warehouse into a separate model and examine the download for issues such as size and excessive detail, and either editto simplify or choose some other model, before placing it in your production model.

As @DaveR found, I also had no problem purging unused item from your model though it took a long time. I agree that likely you have simply overwhelmed your computer with this model.

Edit: I also noticed that you are not using tags appropriately in your model. All edges and faces should remain untagged; only groups and components should use tags. Tags do not prevent edges and faces from interacting with each other, even when set non-visible, and that can lead to strange and frustrating errors.

1 Like

Thank you!!! From now on I definitely will download into a separate model and look more into the file. :))

One more question:

In your cleaned file all the materials are gone or invisible. Should i add materials separately or is there any easier option for that? Are materials/ colors gone or somehow hidden?
I understand that I will need to see plenty of tutorials about how to avoid making my file as big as it was before and probably i will get my answer from there, but if not then asking just in case :slight_smile:

Edit: Now i found it!

Found it!

I saved the file with the Monochrome face style. The materials that were removed weren’t being used.

1 Like

Yes, thank you!