Models not being shown in Sketchup 2023?

Im having trouble importing models into my Sketchup file. The file is far too large to upload here but I’ve shown a video. In this instance I’m trying to import a chair but its not working. It’s been like for several different models I tried. I’ve got the free trial of Sketchup Pro, and I should mention that my drive was running super low on storage when this started, so I changed drives, didn’t work and then I made some space on the original drive. Any help is appreciated.

Share the SketchUp file with us so we can see what you are working with.

By the way, please correct your profile. The “Free plan” is a web based version, not the trial of Pro.

Use wetransfer, dropbox, google drive or any other platform you prefer. We can not give you a solution if we don’t have access to the file, we could spend days trying to guess what’s going on.

Here is the Link:

Here is the Link:

That is a large file. To start with go to Window/Model Info/Statistics and click the purge button. Then save.
Check if it fixed your issue, if not upload it again.

Please correct your forum profile while I look at your file. Box is right. It is a huge file.

I see you’ve hidden a lot of edges. That’ll make your model difficult to work with.

A fair amount of incorrect tag usage. All edges and faces should be created AND remain untagged.
Screenshot - 7_10_2023 , 10_37_10 PM

A little bit of stuff to purge.
Screenshot - 7_10_2023 , 10_39_04 PM

And about 50 excessively large texture images. Typical of content downloaded from the 3D Warehouse and just shoved into the project. A number of excessively detailed components in the model, too. You could stand to do some surgery on them and reduce their level of detail. For example do the tires and wheels on this car add important information to your model?

There’s no tread on the tires on the other SUV.

Does the bottle opener on the tool cart in the gargae tell an important part of your story?

What component were you attempting to insert that you don’t think is being shown?

Looking at the vertical edges on your walls it’s evident that the geometry could tolerate some cleanup. You shouldn’t have all those verticals on the flat walls.

Alright thanks for the info but do you know how I can import more models from 3d warehouse as the models I am importing are not showing. I have a video in the original post showing my issue. I’m trying to get more models in to make the house complete, has it reached a limit and I should delete the smaller models? Or is it something that I’m not understanding.

Your model is unnecessarily big, you should correct the errors that Dave pointed out, and it’s not a good idea to download models from the 3D warehouse directly into your model, you should download them into another file, make some clean up and check if its good enough for you. It seems that you have models with a lot of details that are irrelevant for the entire model, this is causing your file to get laggy and when you try to import a model with even more geometry the program needs a lot of time to do the task.

So is that issue that I just have too much clutter? I should clean it up and then I should be able to add more models?

But download them in another empty file, check if it’s good, clean it up, check the tags and delete all of them, move the geometry to untagged, and check how many entities does it have, for assets you don’t need a chair with millions of entities not even thousands, there is a plugin that helps you to reduce geometry from high poly models, I don’t remember the name right now but it’s a paid one.

One quick test, download the chair into a new model space. If it appears then you know it is related to your model.

1 Like

Downloading the Live Component you tried, into your model, gives me the same symptom. Copying the apparently empty chair into a new document shows the chair ok. Only strange thing I see immediately is that the chair is 209 feet from the origin. Figured that out when I saw the large profiles surrounding the building.

Even after deleting the profiles, and the cars, placing that chair still shows as an empty component. Also reduced the size of the 115 materials that were extra large.

I’m heading to the office soon, I will take a look at the model with one of the developers.

1 Like

Which is why I suggested that test, downloaded in an empty model it behaves ok.
But being a live component it could be something else.

Yeah I’d appreciate that, I’ve taken some advice and started to declutter my model, but I haven’t been able to import anything new into, even after copying the model from a empty document.

Yep its definitely related to my model because I opened a ton of different models into different Sketchup files. I am going to try and uninstall MAJrail and its models because I’ve been starting to have issues only after using that application, I’m not sure if thats the issue but I think its worth a try.

I showed the symptom to a developer, who I happen to sit next to at the office. He had the wisdom to suggest looking at the Outliner, and then we immediately could tell what was wrong…

The model’s Untagged tag had been hidden, even though it was the active tag. That shouldn’t be possible, I’m still trying to figure out the steps to get there. Once I do, I’ll make bug report about it.

Also, when downloading from 3D Warehouse there should be a warning to tell you if you are placing the component into a currently hidden tag. That may not be needed, if the first issue is fixed.


This was it, the problem was driving me crazy but I finally got it thanks to this comment. Thank you, and thanks to that coworker as well.

I did pass on the thanks to my coworker. He was pleased that it helped.