This does not appear to be a SketchUp Model - Help Needed

Having similar issues as some topics on this forum. I am using SketchUp Pro 2020 and I can’t seem to open a file that I was able to open just a month ago or so. I get an error saying “This does not appear to be a SketchUp Model”. I have other files that I am able to open successfully but this particular one is not working.

Can you check for an SKB file in the same folder? If you upload the files somewhere we can take a look.–n6aj3972dUnlB/view?usp=drive_link

You need to grant access to the google drive. We can’t access those links until you do.

Ok, try these links.[](Brother's Keeper - Design.skb - Google Drive)

(post deleted by author)

Hi everyone, I think I got flagged by community and now can’t post the links to allow access. Will try again shortly.

I wonder why you got flagged. What did you post that might have caused that?

Are you using a cracked version of SketchUp perhaps?

(post deleted by author)

The .skb file can be opened in SU2024, at least.

I note some incorrect tag usage.
Screenshot - 6_2_2024 , 3_24_08 PM
And loads of hoarded unused stuff.
Screenshot - 6_2_2024 , 3_25_39 PM
And plenty of excessively large textures.
Screenshot - 6_2_2024 , 3_26_28 PM

After purging and saving the file the size was greatly reduced: 81%.

Did you try opening the .skb file?

The forum flagged you for trying to post the same link five times in a row.

1 Like

Thanks. I had tried the .skb file previously, and it gave me the same error. But I just now opened Sketchup Pro 2020 first and then went into the program and opened the file from within the app, and it just opened. Thanks for flagging the details you noted, I will clean it up to help with the size.