Strange issue with a disappearing SketchUp file

bug
windows
file
2016

#1

I was working on one of my skp. files recently when SketchUp suddenly crashed. I attempted to reopen to the file, only to end up staring at a blank interface. The model was nowhere to be seen, no matter what I did. I checked the model info, and all the faces and edges are still reporting to be there. The file size is unchanged as well. So far, I have tried reopening and reinstalling SketchUp and rebooting the computer, both to no avail. I can open other similar files just fine. It’s only this one that’s giving me issues. Any suggestions? :confused:

Some info:
Running SketchUp 2016 on Windows 10
Using integrated Intel HD graphics.
The file itself is stored in my OneDrive.
The file is available in the 3D warehouse under the name “Front Wing Design (Flawed)”


My whole model disappeared/the screen is blank...?
Model disappeared after SketchUp stopped
Camera Position
#2

You can add warehouse links here so people don’t have to go searching for it.
Did you try Zoom Extents, shortcut is shift z.


#3

Just tried, doesn’t work. Everything that’s supposed to appear in the model interface (layer window, tool options, axis lines, etc.) is not appearing. Right clicking still brings up commands, but I can’t see anything.


#4

There is something very odd happening with that file, I don’t know what.
I was able to recover some parts, don’t know if this is all that was meant to be there.
Perhaps telling us what you were doing when it crashed would help us pinpoint the problem.
Recovered…skp (304.9 KB)


#5

I dont know how Box did his recovery but I opened your model and then exported a 3ds model. I then opened a new session and imported the 3ds (imported in FT). Here is the result. I did notice that the dae export results in the same problem you see in SU and the when trying to export dwg/dxf, an immediate crash occurs.

recovered as 3ds import.skp (515.6 KB)

CD


#6

Thank you both for the help. The recovered files are fully intact, as far as I can tell. I’m still not sure what the issue was. I know I was working on a nested component at the time, but I wasn’t doing anything particularly out of the ordinary. Just a random bug I suppose.
Thanks again!


Crash and blank screen | URGENT |
#7

I was curious, so I dived into the guts of this model. I don’t know exactly how it happened, but it feels like an uncaught divide by zero (or almost zero) bug. Here’s what was wrong:

The heart of the problem is that somehow you got an Edge located at a more than astronomical distance from the origin. At the same time, the view’s camera became singular (its direction is [0,0,0] - i.e. pointing nowhere - and its eye and target are also astronomically far from the model), which is what causes the strange behavior of the view. Using a short Ruby script via the Ruby Console, I deleted the offending Edge and then reset the camera via the GUI. The attached is what resulted.

Front Wing Design - cleaned.skp (308.8 KB)


#8

@slbaumgartner Well done!! Super sluth SteveB

I read your solution and used ThomThom’s CleanUp extension to get rid of any stray edges and YEP… it fixed the issue!

CD


#9

OMG! I’m very, very new to SketchUp & have just had the same thing happen. I was editing a component downloaded from the 3D warehouse & boom nothing!


#10

HELP Please anyone???


#11

@KySarge

Share the model file.


#12

Thanks for you reply but I can’t upload the file! The file is too big! Even zipped! I now think that the last item I down loaded from the 3D warehouse & was editing at the time of the “boom nothing” is the cause as looking at the components, there is only 4 & the stats are huge! I have copy of the model from 2 hours earlier
Here’s the difference…
Now -
Edges 102147
Faces 49519
Component Instances 64
Guides 0
Guide Points 0
Groups 7
Images 0
3d Polylines 0
Section Planes 0
Dimensions 15
Text 0
Classification Types 0
Classified Entities 0
Component Definitions 27
Layers 2
Materials 29
Styles 1

Then -
Edges 188
Faces 76
Component Instances 0
Guides 0
Guide Points 0
Groups 0
Images 0
3d Polylines 0
Section Planes 0
Dimensions 0
Text 0
Classification Types 0
Classified Entities 0
Component Definitions 0
Layers 1
Materials 24
Styles 1

Can I delete an item directly from the component directly from the list?
It’s a Faber: Gala ST (doorkijk) 3 side frameless fire. It had a person it in which I did not want but unfortunately I didn’t check to size of it before I down loaded it.


#13

Open the Components Browser > In Model

There, Right click on the component in question > Delete

Then, Window > Model Info > Statistics > Purge Unused


#14

(ROFL Geo beat on to the reply…)

In the Components inspector, select the component definition, right-click and choose Delete from the popup context menu.

OR

menu Window > dialog Model Info > panel Statistics > button Purge Unused


#15

Ok so that deleted the model & reduced the size somewhat but I’m still in trouble & it’s still too big to up load! :frowning:


#16

Just how big is “still too big” ?

The forum has a 3MB limit.

The 3D Warehouse has a 50MB limit.

You could upload the model to the 3DWH and post the model URL here for others to find the model in 3DWH


#17

You have learned a hard lesson.

Never download “unknown” components directly into your models. Download them into a empty model and inspect them beforehand. (if they are worth it,) you can clean them up, and perhaps use an extension like ThomThom’s SubD to reduce their poly count. Then you can save them locally to one of your user collection folders.


#18

Hi there, Im having trouble with .3ds file importing larger than their original size (2 or 3 times larger), taking a really long time to load (upwards of 40min) and then simply disappearing once loaded. The first two I can deal with/dont worry me too much, but I cant figure out how to get the components to be visible.

I tried the Clean Up extension as suggested above (without the deleting hidden geometry option), and have not had any luck.

The files are over 50MB so heres a screenshot showing the particulars:

  • its zoomed to extents,
  • all on Layer 0 (i.e. not a hidden layer issue)
  • and appears as a component in the components list but is visibly not in the model.

If anyone has any suggestions that might help they would be greatly appreciated. :slight_smile:


#19

If by “larger” you mean that the file size is larger, that is not very surprising. Changing from the original representation of items to the SketchUp model’s representation could easily require more data. Also it is quite common for exported files from other modeling apps to contain finely triangulated surfaces that overwhelm SketchUp, causing both long load times and sluggish behavior once loaded.

Most often when a model seems to have no content it means that the parts of the model are scattered over such a large extent that to view them all at the same time the camera has to zoom out so far that they are all too small to see.