Unable to get individual parts with OpenCutList - it only treats all parts of a component

I’m relatively new to SketchUp and I’m trying to sketch my garden shed. I wanted to use OpenCutList to get a part list of each individual piece I’m going to use.

Following tutorials made me get far - the structure stands, using components, copying, multiplying. Happy.

Now when starting to use Pro to have access to Cutlist extensions, I started using OpenCutlist.

After reading and watching some tutorial I tried to use it with my sketch. Unfortunately I never got the individual part-list as I saw it in the tutorials, but only one part with its measure and count set to 1 for all parts.

So I made a small test sketch and the same, I won’t get any individual part list: here is what I did:

I created a stud with 12x4.6x280 cm, made it a component, gave it a material, copied it once:

Then I open up opencutlist and tried to use a different types, no types (solid wood, dimensional) and other things, but I never got it to tell me that, I have 2 x 12x4.6x280 cm studs, it always presents me the part as one block. (screenshot in a reply, because as a new user, I’m not allowed to have 2 medias in a post.)

Where is my mistake?


Here’s what I get in opencutlist

Probably copied the geometry of the stud while editing it.
Upload the .skp here to check!

Copying the geometry, if it’s that, I’m not sure how I did it and how to avoid it.

test.skp (117.2 KB)

I think I found my error, I was duplicating a new stud while being in a component selection mode, to it seems it made a whole component out of every stud I copied in the mode.

Pity, I’m unable to split the parts from this component without losing the component (explode) and thus opencutlist does not see any components any longer.

In selection mode (Spacebar), try avoid clicking to much (I now you’re eager:)

1 click = Select object
2 clicks = Open for editing(!)
3 clicks = Open for editing and selecting all connected geometry(!!!)

Because you want to copy the stud, activating the move tool should be enough, it let’s you select the object as well.

This seems to be a common new user error. The clue is the size of the blue bounding box when you select the component. In the case of the stud, the bounding box should fit the geometry of one stud tightly. Also look at Outliner. It would show one object selected when it appears in the model space as two.

I think you were in component edit mode.

You don’t need to explode the component. Open it for editing and select and delete the excess geometry. Then exit edit mode and copy the component properly.

1 Like

My error was that I wasn’t 100% looking what the tutorial makers did. I just heard them saying, triple click to make a component.

What I now see, but not understood in the first place, once you have the component, it is single click before to copy it.

Yes. Triple click is one way to select all of the connected geometry before creating a component. Triple clicking on a component with Select opens the component for editing AND selects all of the connected geometry within the component.

FWIW, it should be a rare thing that you would need to explode a component after creating it. You should be able to do everything you need by editing it.