Unable to download any version

hello,

Can you try again from this page ? all downloads

Even though that looks like a different page (your link pointed to a download for a French version, but I don’t speak French), the links are the same as on the page I posted. I tried the link for SketchUp Make 2017, but I got the same result: Interrupted: Forbidden. I thought it might be a failure on my part to click an accept button on the Terms and Conditions link on all the download pages, but there’s no such button or facility.

It seems there’s something blocking me from the SketchUp end, as I’ve no problems getting other things to DL

:confused:

sorry, my bad for the french page ! It might then be your firewall that is preventing the download. Do you have any activated ?

Check your firewall and antivirus.

By the way, in the link above you just need to change fr to en and it will give you the English page.

My firewall is down so that I can download. I’ve cleared everything I can from my end- I have no problem downloading other software (even SketchUp’s own CheckUp app). So it seems to be something preventing the download at the other (server) end.

if no firewall nor antivirus is “protecting” you, you should try using a proxy such as Webproxy that has an extension for chrome. I’m not sure because I’ve never faced this problem but since you seem to be blocked for some reason I believe you should give it a try !

It’s a much larger file than the checkup one. It could be timing out somehow and throwing the forbidden error. I doubt it us on the SU end.

he is trying on chrome and opera

It’s not timing out. It’s a 148mb download. When it gets to 140mb, it reports that it has stopped for the Forbidden reason.

I have been able to download much larger files without problems. I would use SketchUp Free (the browser version) but my broadband connection is too poor for that

no probs here, check the log of your malware scanner or disable during download.

make sure you download the correct version. 32 bits or 64 bits according to your OS. seems like someone else had the very same problem here

As I said- that has been done. Did you download the entire file without trouble?

Perhaps it’s a regional glitch: I’m based in Ireland.

The version I have been trying to download is SketchUp Make 2016, Windows 64-bit 16.1.1449; Windows 10, 8, 7
The page I originally cited is less important: all the download pages- in whatever language- will all still point to the one link for that build: http://dl.trimble.com/sketchup/2016/en/SketchUpMake-2016-1-1449-80430-en-x64.exe. It’s the English language version. TBH I had hoped that an Admin from Trimble or SketchUp would answer- I might just see if it’s possible to send a message directly to one of those, as my constant frustrated attempts are driving me crazy!

I understand, but are you sure you’re not running a 32 bits windows ? because the guy in the topic I sent you had the same problem and it disappeared downloading the 32bits version. This one :

http://dl.trimble.com/sketchup/2016/en/SketchUpMake-2016-1-1450-80430-en-x86.exe

Paul
Thanks, but my system is 64 bit.

Have you tried FF or IE. It really sounds like something strange on your end, perhaps your isp, as you mentioned it isn’t perfect.

If your internet connection has faults, you might try using a download manager when downloading. They can usually resume a broken connection etc. If, at home, you are using WIFI to connect to your modem/router you might try using a cable instead.

Could you post a screenshot of the “forbidden” message next time? It’s not clear what is raising this message. Perhaps a screenshot will help us to get to the root.

1 Like

Caroline

Forgive me for reposting something I’ve said elsewhere, but I’m struggling to download Make.
This is what I posted in a post earlier today:

I’ve used SketchUp for years, going all the way back to before it became part of Google.
When I recently had to replace my computer, I moved from an old Mac to a new PC.
I wanted to install SU on the PC itself, as I live in a rural area with a very poor connection, so SketchUp Free isn’t an option. I went to https://help.sketchup.com/en/article/60107 to download the appropriate version. I ran Checkup first, to make sure that my laptop is compatible (it is!).
Now for the problem- every attempt to download a version, whether within Google Chrome or Opera or using Ninja Download Manager fails and I’m told Forbidden.
Can anyone suggest a way that I can successfully download a version of Make that will function on my setup? Thanks

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.