I am unable to Download Sketchup

I cannot download sketchup. I get the following error in Chrome and Explorer (Windows), trying to load -

From this page http://www.sketchup.com/download
I am directed to
http://dl.trimble.com/sketchup/SketchUpMake-en-x64.exe

and get the error message:

Unable to load the webpage because the server sent no data.
Error code: ERR_EMPTY_RESPONSE

Just tried it. It worked. Try again.

exact same result.
It is so frustrating, over 2 browsers.

I can download anything on this ( http://www.sketchup.com/download/all) page EXCEPT the windows 64 bit version of sketchup

hmmm looking at the firewall, it does not like .exe

Why is there no YEAR by the date of these comments? I have no idea what year these were posted and things could have changed with Sketchup. I can not download it, this is 2018. It keeps directing me to use it within my browser instead which does not give you all the tools I see on the downloaded versions. What is going on?

I do now see the year only became visible after I replied??

Things have changed in the last two years.

There is SketchUp Free for using on your browser but you can download SketchUp Make 2017 if you want to use that instead. Of course both are for non-commercial use. Otherwise you should be using SketchUp 2018 Pro.

Thank You what about 2017 PRO? Is it the same thing?

SU 2017 Pro can be downloaded from the link I provided but it is not the current version so you wouldn’t be able to buy a license for it.

Oh so I should rather download Sketchup Make 2017? That would be OK?

You can use SketchUp Make for hobby use. If you are using SketchUp in your business or for other commercial use, you must use SketchUp Pro.

OK Thank you :slight_smile: