Unable to create a component, Program hangs

I’m trying to create a component in SketchUp 2022. When I select Make Component from the context menu (right click with an object selected) the program hangs. The only way out is to go to the Task Manager and kill the program. I never see the dialog box to name and create the component, it shows the axis, but nothing else. I’ve tried this in a new file as well as in a file where I already have components. The result is the same, a hard lockup.
This started some time ago and I think it was after a Windows update, but I can’t confirm that.
What I tried:

  1. Did an uninstall and then did an install.
  2. Did a modify run as administrator.
  3. Did an uninstall of 2022 and 2021. Did an install run as administrator (I’m administrator on my machine, so “Run as Administrator” shouldn’t be necessary).

Please help. I’m getting very tired of only being able to create “groups” and then having to individually modify them if a change is required.

If I understand how this works, a database is queried, and the object is kept there. Is it possible the database is not replaced with a new install or uninstall and has become corrupted? If so, how do I delete the database so a new one will be created?


Have a look here.

I am very embarrassed to admit. This was one of the first key combinations I learned when I started to work at Microsoft. We were always getting dialogs caught off screen and this is the way to get them back.

Thanks you for your time and this hint. Maybe it will help others.