Two attached townhome units - can't change material colors

I have a townhouse model I’m working on as a practice model. I am working on a 5-plex townhome building and an 8-plex. Everything seems to be working fine, with one exception. I have two units sde-by-side in my 5-plex where I can’t use different colors. Whatever color I use on one bleeds across into the other one. My lines separating the units are connected with no gaps, so I can’t figure out why one would bleed into the other. Below is how my building currently looks. I’m trying to make the middle unit white while keeping the ones on each side gray. I haven’t had this problem with my 8-plex and I’m puzzled as to why this building is doing it. The gray unit on the left is bleeding into the middle unit.

You will need to upload the .skp model to the forum for us to diagnose.

Are your units separate components? If not, they probably should be, but if not can you select only the face you want to color, or does the selection include other faces?

1 Like

I used separate components on my 8-plex but when I made changes to the 5-plex only, I forgot to make them separate components. When I select the face of the middle unit, it also is selecting the unit on the left, the one that is bleeding into it.

Do you still need to see the model? I can upload if still needed.

Thank you.

There are a lot of problems in my model that I’m working on as I’m still learning, but this particular one I just don’t understand.

This indicates that they are indeed a single face, and not separated. Re-examine the dividing line closely and look for gaps. If you share the model someone might be able to find the gap faster.

Thank you so much for your feedback. The forum says my model is too large to upload.

Ah, yes, there is a file size limit. you can use a sharing service like dropbox or google drive and post the link here.
Or select the troublesome wall and copy it, open a fresh file and paste it in, then post that.

Let’s try this. I went ahead and made a file with just the building in question for clarity.

Got it. Looking now…

Thanks. I hope you can navigate through the mess that is my model!!

No problem. You would certainly be better served by making use of groups and components to isolate geometry. Working with all raw interconnected geometry you are making your life much harder than it needs to be. The line you think divides the two is not actually on that plane, it is in front of it. I change the Camera>field of view to something reasonable like 35˚ (you have it set to over 100˚ which distorts things badly, like looking through a fish eye lens).

Then I selected and made a component of the wall, simply so I can open it for editing with the rest of the model hidden to see what is going on. I draw the edge where I want it then close. If you want to continue with raw geometry you can then explode the component.



Oh my, thank you so much. I could learn a lot from you, so I am glad I found these forums!

May I ask what extension you used that has the colored pencils? That looks awesome.

Thank you again, you are a life saver!

1 Like

No problem, happy to help. Look under View>Component edit for the settings which hide the rest of the model when editing. The colored pencils are not an extension, that’s part of the materials pallet interface on the Mac version.

Oh cool, I think I like the Mac version better based on that one thing alone! :slight_smile:

Thank you again.


1 Like

Honestly there are a few small plusses and minuses both ways, there are some parts of the Windows interface that I am jealous of too, but mostly they are the same.


1 Like

The Mac system colour palette looks good but remember quite many forum posts with Mac users wishing that both versions would use the same, Windows version-style material selector. The palette/tray in the Windows version was designed by the SketchUp team while the Mac one is from the OS. Windows has no built-in equivalent.

1 Like