Twilight render scene smaller than sketchup scene

excuse me for probably asking a stupid question. i am an absolute beginner both in sketch up and with twilight. the following problem: i have saved my camera settings as a scene and want to render them. no matter which format i set and whether i switch on or off in the settings “section section rendering”. only a small part of the sketch up scene is rendered at a time. i’m sure it’s very easy to solve this phenomenon. i thank you in advance!

check if “'Fit to View Proportions” under camera settings is on

i’m not familiar with twilight but according to their website :
Clicking the Zoom button will set your Width and Height to exactly the current SketchUp view size

you might also want to try that !

thanks for your fast answer. unfortunately, the problem remains the same :frowning:

it is strange because it seems twilight keeps the exact focal length that is set up in sketchup but crops the image. Perhaps the resolution is tight to another parameter. Have you tried increasing it ?

I’ve tried. nothing. but this could be the problem? i do the following: i position the camera and render the scene. then it works normally with the cropping. then i say “two point perspective” and zoom out the sketchup scene. the angle of view distorts a bit but i see everything i want to see. then i render and twilight cuts the picture so strangely .

when you zoom out and in inside sketchup while in two point perspective, it actually changes the focal length (field of view). you can do it as well with the zoom tool entering its value at the bottom or click&slide holding shift.

That’s what you can do to see everything you want to see. But it is strange that it doesn’t match your scene if “fit proportions” is checked.
In vray a safe frame is shown, showing you what is going to be rendered.
Apparently in twilight it’s thin red lines, see there : Twilight Aspect ratio "bars" in sketchup view? Possible? - Twilight Render User Forum

1 Like

Try this and see if something changes:

1 Like

that doesn’t solve my problem but it’s very helpful anyway! thx

thank you for researching. i found another helpful contribution in the forum that confirms my idea: “Twilight Render will render a 2-point perspective but will not register if the camera is panned. Do not pan the camera after setting 2-point perspective.”
that seems to be the problem.

If you change scenes settings without saving them, then will still render your original settings.

//edit: I see you have found the same explanation and solution :wink:

1 Like