Trying to create angled arcs, curviloft


#1

Hi im trying to create an arc between different height areas.
I always run into problems, been a while since i used sketchup but have used curviloft before and now cant seem to get anything to work how i want. :frowning:
Any help much appreciated!


#2

How about sharing the SKP file?


#3

streetsetup.skp (52.8 KB)

think thats it


#4

Is this what you are trying to achieve?


#5

yep pretty much, that would be perfect :slight_smile:
how did u do that?


#6

I drew in edges between the bottom end of the arc and the upper and lower ends of the ramp. Then I selected the arc and the edges extending from its ends before running curviloft.

I did it in two operations but you could select the four bordering edges and arc and run it in one.

Make sure you are correcting face orientation as you go. No exposed blue faces.


#7

ok ok thanks!
…i was on the right track but ended up deleting those lines because i thought something was off.
Ill try again, thanks for that!


#8

A lot of faces in your model were reversed too, which I imagine Dave fixed before doing the extra lines.


#9

@colin has a point. I did fix them before making the screen shot. I also mentioned that you should be correcting them.


#10

The native Sandbox from Contours tool also fills the shape quite neatly after adding the two edges like DaveR did.

Anssi


#11

oh, ok not sure how i check that, but thanks.
no exposed blues faces… not sure what i have done to get them?!


#12

oh ok mite look into, since i often have these types of shapes to fill on projects. thanks


#13

I don’t think that sandbox handles curves very well. I tested it out and it wasn’t a smooth curved surface. I used the contour option, is there a different way to achieve a smooth curve with sandbox?


#14

In the screen shot in your first post, the darker faces are all reversed. Generally it has to do with the way you go about making the form 3D. It’s not a big deal if it happens but you want to get in the habit of correcting them when you have them on the 3D form. You’ll notice in my screen shots, the faces that showed reversed in your image are corrected.


#15

ok cheers ill check that