Trouble Signing RBZ

Hi, i am trying to sign / encrypt an RBZ of my extension, but i keep getting an error
“Oh No! There were some issues with your extension, please contact support.” I also get this on a file i signed last week without any problems.
This happened before, but mostly that was a server glitch and only lasted an hour orso. This already lasts a day.
Anyone ideas?

1 Like

Hi. We’ve gotten multiple reports of this today. Looks to be a service issue. I’ll report back once we know more.


Great!! Thanx TomTom. How have you been?


Just tried signing the latest iteration of the Medeek Wall extension (Version 2.5.3) and no matter what I do I’m getting this error:

I’ve checked and double checked my .rbz file to make sure everything is in order (trust me I’ve done this now for well over 300 releases/updates of this plugin) and everything is in order.

Please escalate this it needs to be fixed ASAP. I am unable to push out new releases and bug fixes until this is resolved.

While I’m on the subject of extension signing, they really need to fix the algorithm so that it ignores text files that are found within the plugin folder(s). The signing algorithm should only be looking at the actual .rb or .rbe files. This is a real pet peeve of mine since I use some simple text files for various settings and logging data. Once the users starting use my extensions they will then go from a valid signature to an invalid signature, very annoying.

I’m experiencing the same issue.

I stripped my build down to just the .rb files and was able to generate the rbz. It appears that we cannot have any other file types (txt, html…)

1 Like

Did they change the signing system without any notification? Again?

I’m very confused.

My plugins are very complex and large now, lots of html, images (jpegs, gifs, pngs), javascript, text files etc… I also have quite a few pre-configured components (.skp - SketchUp files) for various construction hardware such as Simpson hangers and column and post caps to mention a few.

What am I supposed to do now?

Please don’t break or change the signing system, at least not without a month or two of advanced warning. This is my bread and butter now, I rely on this system to work.

So what are you supposed to do?

Do you pull everything out except for the .rb files and then once the .rbz is generated you put the misc. html, text files etc… back into the .rbz file?

Please tell me this is just a server glitch and not some unannounced reworking of the signing system.

Interesting clue.

Not intentionally. This would be a bug.

Same here.

Can anyone with issues send up their original RBZ they try to upload to please.

It’d help to have the actual RBZs being uploaded. Internal tests showed RBZs working. But I’ll be testing what @Palo described. (But please send us the RBZs anyway so we can make sure we test all scenarios. Might be multiple triggers here.)

1 Like

Server logs are showing signings of RBZs with files other than .rb files. RBZs that include images etc. So there’s more to this. I’ve yet to find the logs for your submissions though. (So original RBZs would be very helpful)

1 Like

What was the name of your extension?

Done. Thanks!

1 Like

I guess that this happens because the extension modifies its own files so SketchUp cannot guarantee that the content is legit, right?

For our extensions, we do not modify the extension files. Files that need to change (temp stuff, logs…) are stored out of the extension install folder (in AppData on Windows and the equivalent folder on Mac) and we don’t have this signature invalidation issue.

Send my RBZ file

Lets take this into a separate thread please, as it’s not directly related to the ongoing issue. (Helps us in keeping track on things.)


I don’t think the problem is the auxiliary files. I somehow get the feeling that the zip is somehow corrupt from the point of view of the signing system. Rezipping after some random tiny change to the code has always fixed the issue for me. It has occurred maybe five times over the last year.

I don’t think that is the problem. I keep a history of all my rbz builds and I cannot sign those either.

I thought that maybe this is a windows 11 issue, so have tried on a windows 10 machine… same result.

I was able to repo this on the failing extensions I have received so far. This is a very strange regressions. We’re not sure what might be prompted it. Actively investigating.

1 Like

That fact that I cannot get any of my older unsigned .rbz files to sign successfully tells me that something must have changed with the algorithm. Hopefully we can restore this to its previous working state.

Thank-you @tt_su for working on this, I really appreciate it.

@tt_su Is the EW signing service reflected on ?

1 Like