Trouble signing in/ access trimble connect etc

Hi there
I’m having trouble signing into trimble connect on Safari (Mac OS), though I can sign in on Chrome on the same machine.

Within Sketchup, I can’t access trimble connect to open or save a model. If I download a model using Chrome and then open it I get token error messages in Sketchup saying I’m not logged in etc. The little icon in the top right corner of sketchup says I’m logged in, and if I check license within sketchup the function times out.

Anyone have any ideas what to do to get back working? Seeing similar issues?

Same issue here … my entire team is having the same issue. All Mac OS.

Logged out, rebooted, etc etc. Same result.

Can log into Trimble site, but has no effect on SU.

Okay, seem to have fixed it. Here’s what I did:

After I rebooted and opened SU, the first model it shows in the opening dialog I was able to open. No other files, and no new files.

In the upper right corner of the file I WAS able to open, there is the icon that shows your license status. If you right click, you get the option to LOG OUT. Do that … then log back in.

I think the token somehow got stuck on the last file I was working on?

No I think there is a problem with Trimble and SketchUp. Same thing here. Please resolve ASAP guys and gals!

This is a bug that I hope is fixed at some point. The solution is linked below.

In short: you have to log out using the Help menu, then log back in using the same Help menu.

All this logging in is inappropriate IMO. I login 10% as often on something like Adobe CC.

This approach worked, thank you Dack.

I am with you, the frequent sign in requirements is annoying. More so when trying to use the software in the field and then being locked out without wifi etc. I’ve mostly learned to sign in fresh before I leave the office, but it’s annoying when I have forgotten.

Bumping this thread as today the approach outlined above isn’t working… or not fully.

I can log in, but things time out when I try to log into trimble connect to open a model. I can successfully open a model within the single project folder that opens, but I can’t access the larger list of other projects or those models. Anyone have any ideas to make this work?

Hold Ctrl and tap F5 a few times, this will refresh the page of the browser.
On Mac, use Option + Cmd + R

same problem here - I have an email from trimble with my authorization, but no way to reach a login box. all I get is unresponsive “sign in” tabs. Killing my work flow here.

I’m still unable to open models from connect within sketchup, the browser opens and then just spins indefinitely. Anyone sort out a solution here? I’ve logged out via the help menu, and logged back in without issue… but then can’t connect to open projects etc.

After signing out, close the app.
Then restart SKetchUp

Unfortunately, that didn’t do it either.

Do the projects have the default icons in
There is an issue,
Check this thread:
Two Trimble Connect issues

Thanks- that seems to be working


This topic was automatically closed after 186 days. New replies are no longer allowed.