Trimble Connect extension fails

When I try to open any of the Trimble Connect extension windows, the window appears, then immediately closes. The exact same thing happened to another user last year: Trimble cannot log in - #4 by workinghard

It seems related to credentials. I had to sign out of SketchUp (Help > Sign Out). Then I had to sign back in to SketchUp, and then when I tried to open Trimble Connect it prompted me with another window saying I had to sign in. So basically I had to sign in twice.

There seems to be a bug. Is Trimble Connect supposed to share the credentials from the SketchUp sign in? Or is it expected that you have to sign in twice? Either way, if the credentials fail, it should prompt the user, instead of just immediately closing the window without providing any indication of what went wrong.

Hi Matt,
Hope you are well. The same thing happened to me two weeks ago. If my memory serves me, I restarted my computer and then it worked just fine, but I’m not positive. I don’t think I signed out and in again.
I wonder if there’s a way to force-reproduce this event to learn more about it.

1 Like

Yeah, I was able to fix it. The frustration is how it doesn’t prompt you to say there’s a credential error.

Not to mention, the number of times I’m forced to sign into Trimble is so annoying, lol. Idk why, but there are some days I have to sign in like 4 times. Sometimes it’s SketchUp, sometimes it’s 3D warehouse, sometimes it’s Trimble Connect, sometimes it’s the forum. It doesn’t seem to remember me being logged in sometimes.

Part of it is because I have so many devices I test on, so I’m having to go to “manage devices” in my account, which doesn’t actually let me manage my devices, it just forces me to log out of all of them, which means I have to log back in, multiple times, all over again. It would be great if I could select the specific device to deauthorize, so I don’t have to log out of all my devices.

It’s just not a fun user experience.

I haven’t been able to put my finger on it to reproduce, unfortunately.

I’m having the same problem. Both at work and at home, so two separate workstations are having the same problem. The windows close immediately upon attempting to open, so I have no chance to correct it or even see what’s happening. Both workstations are cycled off nightly.

1 Like

Does signing out of SketchUp and signing back in again fix it for you?

It seems to be better now. I keep forgetting that it’s a persistent logon that should be refreshed occasionally. We’ve also been having intermittent internet outages, so that doesn’t help.
That’s specifically why I never want to go fully web dependent. If the signal isn’t perfectly clear during upload/download, there can be corruptions. Many thanks for SU/Trimble for being such a responsive company.

SSO (Single Sign On) was introduced last week:
https://www.trimble.com/Support/trimble-identity-update.aspx

From now on, it should be given a more friendly user experience.

To start fresh, you could reset all devices and clear some caches of the standard browser you are using.

1 Like