Sign in problems; Trimble website doesn't respond


Hi, when i try to start up SketchUp (Pro 2021) I am prompted to sign in. But when I try to do that I get redirected to a static Trimble page where I can’t do anything… I’ve tried loads of things, but basicly I’m locked out of my software for two days now :frowning: Can anybody help? Attached a screenshot of the Trimble page I get stuck on (Safari and Chrome).

I have looked in to this a bit more and since I haven’t signed in since january 16th, I am guessing I have to follow these suggestions Frequently Asked Questions About Trimble Identity | SketchUp Help

I ended up asking Customer Support sending this: “…I have tried loads of things, but I found that I accidentally used Hide My Email form my Apple account, so I am guessing that’s the problem. I have disabled this in my Apple ID settings, but I still can’t get SU to start up…” I am guessing that’s the problem, but before january 16th all was fine, waiting for a reaction now.

I finally fixed it! So I needed to log out, which is not doable when you can’t log in. So I had to delete the private relay address within my Apple ID, use a new and fresh browser (Brave), after that I could login again with a new Apple ID and my standard email address and now I’m able to use my Trimble account, finally :slight_smile: