Trouble Rescaling Sketchup Model

I have been having a lot of trouble rescaling my Sketchup model. I worked on the file in AutoCAD initially and then I imported it into SketchUp. My map’s scale is below the right corner of the map and the midway point is supposed to be 20 feet. When I first transferred my file to SketchUp the units were switched to inches, so I switched the units back to feet and the scale of everything within the map is off. Every time I verify that I want to rescale the model with the tape measure tool it does nothing to change the map. The triangles in the center of the map are 4.5 feet on the shorter sides. The length and width of the star in the middle is supposed to be 7.5 ft. I have my map’s file attached below and any suggestions would be greatly appreciated! Thank you.

IslmicGarden.skp (192.5 KB)

What version of SketchUp are you actually using? Your profile says you are using SketchUp Pro 2022 but you posted in the SketchUp for Web category.

I am using Sketchup Pro 2022

OK. So before you measure across the star with the Tape Measure tool tap Ctrl. (Pay attention to the lower left corner of the model window where it tells you to do this.

Note that components you imported will not get resized this way. In this case there’s probably no reason not to explode them first, though.

I moved your post into the right category based on the version you are using.

FWIW, I would suggest that you redraw your model using the imported CAD line work only as a reference. There’s a lot of bad geometry from your CAD file and I think you’ll find that trying to use it for your model will create more trouble for you than it’s worth… After you get the model sized correctly group all of the geometry so you can refer to it but not use that geometry in your model. When you’ve finished with it, delete that group.

Here are just two examples for you.

A triangle with 5 edges.
Screenshot - 2_27_2023 , 8_04_59 AM

And this shape should have eight edges, not 22.

Thank you very much for all of your help! I really appreciate it!

Do you have any idea why rescaling the map with the tape measure tool may not be doing anything? I have rescaled lots of maps this way in the past and it worked. But when I verify that I want to rescale the map it still never changes the scale of anything in the drawing. Could this be due to the extra lines in my drawing?

Are you getting the message about resizing the model with the warning that imported components won’t be resized? After exploding all the imported objects in the model it resized fine for me.

It’s not due to the awful linework from your imported CAD file.

By the way, are these the kinds of dimensions you really want to work with in your model?

The scale of the pergola pieces and parts I noticed were off as well with scale. I took a little photo of the two pieces I am talking about but the longer faces of the pergola are each 20 feet in length (or at least supposed to be.) A photo of these two specific pergola faces is attached below.

Yes when I tried to rescale components within the map it gave me the message that imported components won’t be resized. I am still not fully sure I understand that message. It makes it sound like it won’t resize anything in the map since I imported all of these things together as one drawing.

As I told you before, explode the imported components and then they will resize with the rest of the geometry.

I do have another question. This has never happened to me before while trying to rescale my sketchup model. Right now my map in sketchup is white because I filled in the map with the pencil tool to make my objects solid. Everytime I verify that I want to rescale my model it turns the entire drawing back to grey and it still doesn’t rescale anything for me.

Upload the latest iteration of the file. It sounds as if you are set on using the imported line work in your model instead of just as a reference.

1 Like

I would redraw my model but sadly with the small amount of time I already have I don’t have the time to redraw it all especially because the entire map is scaled super specific

I think you’re spending way more time trying to fix the bad geometry than it would take to model the thing correctly from scratch.

Are these kinds of dimensions correct? Shouldn’t this design be symmetrical?


Yeah those dimensions look pretty good. The design is supposed to be truly symmetrical but my teacher says it is ok if it is a little bit off. I was able to finally get the scale correct. Thank you very much for helping me with that!

It would be easy in SketchUp to model it so it is perfectly symmetrical but if it’s good enough as it is…

Good luck with the project.

1 Like