Trouble getting faces

OK, having posted earlier that I want to replicate a car emblem I tried my hand at tracing the emblem image (attached). I have also attached my effort.

Now, I have a problem in that I cannot figure out (1) why I can’t make faces that will be extruded and (2) how to extrude the face(s) so that the final object is a beveled (about 1/4").

Attached is both the picture of the emblem and the sketchup file.

Any help appreciated.

Delray_2.skp (328.0 KB)

They don’t form faces because your curves aren’t planar. The Z values for all of the points on the curves need to be the same. Yours aren’t in this small sample. Also, note how the curved on the right disappears under the face that is there.

You need to make sure all edges are on the same plane. One way to do that would be to use the Sandbox Tools to drape those edges you’ve got onto a flat rectangle.

Thanks but…

Since I am new at Sketchup I don’t understand why this happened. I drew the arcs/lines on the same layer so how did they “change plane”?

Also, how did you figure this out? Is there a plugin that can help me?


Layers are not planes in the model space. Layers, now called tags, are only properties that get assigned to groups and components to allow visibility control. You are modeling in 3D space so it’s quite easy to create 3D shapes.

No need for any plugins to figure this out. I changed the Units precision setting to show more places right of the decimal. While I was in there I also turned off Length Snapping but that’s not required to find the problem.

Then I used the Text tool to add labels at endpoints along the curves. By default the Text tool will place the coordinates of the endpoint you click on.

The Sandbox tools are a native extension which you should have access to in SketchUp 2019.

Draw a rectangle below the curves, select the curves and the rectangle and run Drape.

DaveR, thanks for this. However, I do have another couple of questions.

  1. Since I have this, how do I get those lines to be on the same plane as the others?

  2. Is there some way to assure that all the lines go on the same plane?

  3. Once they do get on the same plane and the faces are there, how can I easily get the center line to go up about 1/4 inch?

I am still learning this and am trying but… still have issues.


As I said in my previous post you can use Drape from the Sandbox tools. That’s probably the easiest and most direct way.

Do you mean at the time you are drawing the edges in the first place? Probably the best thing is to start with a large rectangle to draw on and watch to see that you get “On Face” inference messages.

Select them and use the Move tool. You can press the up arrow key to lock the movement in the blue direction. Make sure you have Length Snapping disabled. (Model Info>Units.)

You might find it less frustrating to first learn to use the basic tools thoroughly and work with a simpler model. Even just one letter instead.