Trouble converting DAE to FBX


#1

I exported a DAE file from SketchUp. When I view the dae file in the Autodesk FBX viewer it looks fine. But then when I use the Autodesk FBX converter, it creates the FBX file but nothing is there. When I view the FBX file in the FBX viewer, it’s empty.

Has anyone encountered the same problem?


#2

I used to use the FBX converter to get the Collada files into Unity, but Unity takes Collada ok these days.

Which year FBX Converter are you using? Can you post an example problem file here?


#3

Im using the 2013 one, binary, embed media. Don’t get whats going on. Can’t see it at all in the preview.


#4

I think that is the newest one there is. Have you tried the FBX exporter in SU Pro for comparison?

Anssi


#5

When I did a quick test earlier I found the square face I made was not textured in the FBX viewer, after converting. I took it into Unity and found it was blank there too, but if I looked underneath the texture was there.

So, is seems like if you put a texture on a face that is reversed, it won’t be seen in the FBX viewer. I did another test where I made sure the front face was on top, and then that one showed up correctly in FBX viewer.

The same model exported as FBX was invisible when looked at with the FBX viewer.


#6

I dont have the pro version anymore, but when I did, exporting as fbx gave me problems like not exporting with texture. When I export the dae it looks correct. Just trying to convert to fbx and have it actually appear.


#7

I also had that problem, and corrected it by making sure I had the right side faces. Now all I need to do is figure out how to convert my file to fbx.


#8

Do you have a sample DAE export file I can try?


#9

Sure, here is the file I’m trying to convert.skyscraper.dae (2.5 MB)


#10

Hey so have you had any luck converting it?


#11

Here is the FBX as exported from SketchUp Pro:Untitled.zip (1.0 MB)

I had to zip it as it is over 3MB. It has obviously no textures as your DAE didn’t have any either (the SketchUp importer reported them as missing).

Anssi


#12

Thats weird, I can view the textures fine if I view the dae in autodesk fbx viewer. Which options should I have checked and unchecked when I export the dae?


#13

The viewer probably finds the textures in their original location on your harddisk.

Anssi


#14

I see. When you export a dae which options do you leave checked?


#15

My exports are usually into CAD formats so I don’t have much experience about DAE.
This is how the default DAE export settings look like in my computer:

“Two-Sided faces” is an option that doubles your model size. It is useful only if you export a model that must have both sides of a face visible (like a flag, for instance) to an application that doesn’t support the display of back sides of faces.

The “Triangulate” option might have a big difference to whether an application can process the DAE file, as not all support faces with more than three vertices, so if an application cannot open or display your file, thia would be one of the first options to test.

If you check the “Export texture maps” option SketchUp creates a folder with the same name as your exported file, and puts copies of all your texture images there. If you move the DAE file elsewhere without the texture folder, applications you use to open the DAE won’t find the images.

Anssi


#16

Thanks I appreciate it


#17

hey exporting using sketchup default fixed the problem. i was able to convert to fbx just fine. thanks!