Trouble changing between imported textures

textures
paintbucket
import
mac

#1

Hi, I’m new to Sketchup and the forums. Did a quick search and can’t seem to find the answer to my problem so I hope y’all can help. I am trying to import a new group of wood textures into SketchUp Make 2017 and am not sure of the proper way to do that. To get the textures, I found this file on the 3d warehouse:

To import the textures I opened the materials window, then the texture palettes (brick icon) tab, then on drop-down list opened “colors in model.” I then clicked the “list” drop-down below and selected “duplicate” and named the new list.

The textures are now available when opening a new drawing, however the problem I am having is that the textures are not painting the same way as other textures and colors in SketchUp. When I first select a texture from the group, using the paintbucket tool it paints fine but when I try to select a different texture from the same group and then click to paint it, instead it will paint the previous texture I had selected not the one I wanted. If I switch to a different texture palette (not imported) I do not have this problem.

Is there another method of getting these textures that does not have this problem? Has anyone else experienced this issue? Would appreciate any help.


#2

Yup, I’ve replicated that, and with a collection from SketchUcation as well. For a moment I got it to work by going back to the selection tool in between painting (which you shouldn’t have to do), but now even that’s not working. The back row is standard crayon colors which worked just as expected.


#3

Playing with this more, it’s definitely buggy. All the textures built in to SU can be picked and painted as expected, but so far any custom collection I’ve saved seems to have this problem.


#4

Glad to know it’s not just me. I actually stumbled on a fix by accident but it is somewhat tedious. After duplicating the original palette I went to the new palette and right clicked one of the textures and chose “duplicate” to make a copy of it. The duplicated texture functions properly. I did this with all the textures and deleted the originals and now it works just fine. That being said, it’s a tedious process so I expect there’s a simpler way to fix the issue.


#5

Yeah, really. So is this a bug the SketchUp Team needs to address?