Problems creating new Materials Lists in Sketchup Pro 2021

I’ve just struck a strange problem when creating new material palettes which I haven’t seen before (I don’t think).

If I create three test faces in a new model and then import three different images as textures assigning each to a different face I can then go to the Colors-in-Model list, click on Duplicate, rename the duplicate list to something appropriate and then use the materials just like any built-in list. All fine and dandy.

But, if I:

  • create three new faces
  • load in a material collection from 3DWarehouse such as the free Skalp collection then:
  • select a material using Cmd-Click in the Paint Bucket tool and paint the first face and repeat twice more with different materials
  • go to Colors-in-Model and duplicate the list and rename it, say, ‘Test Materials’
  • delete all three faces, purge the colors in the Colors-in-Model palette
  • draw three new faces
  • go to the ‘Test Materials’ list and fill all three faces with successive materials …

the result is that all three faces are filled with the material that is first to be selected.

This is where it gets strange. If instead of using the Paint Bucket and click-on-face approach I drag the material from the list to the face then the correct material gets painted.

This is all on an iMac running Catalina and Sketchup Pro 21.0.3912.

Now it gets weirder. If I do the same thing on my macBook running Big Sur and the same release of Sketchup Pro I find I can’t drag and drop materials. What I can do is

  • select a material in the new list
  • in the edit pane below set the transparency to 99%

then the Paint Bucket tool paints the correct material (this also works on the iMac as well as the drag-and-drop approach).

Any suggestions as to what’s wrong or where I have misunderstood the whole process would be very welcome.

SOLUTION FOUND (sort of)

I’ve just discovered that if I load a material collection (say the Skalp collection) into my model then drag each material down one by one from the Colors-in-Model list to the palette area, create a new list and drag from the palette one-by-one up into the new list, then I can use the Paint Bucket as intended. That’s 204 drag actions! Plus, if you want to clear the palette, on a mac you have to drag each color swatch into the trash bin - another 102 drags. What a drag.

You should restart between these steps, SketchUp will only load new lists upon restart.
This has been so for the last 5 versions or so(can’t remember if it ever was different)

Sorry Mike but that doesn’t work for me. I’ve just gone through the process again and these are the steps I made:

  1. I started with a new model with no Colors in Model apart from the default. I draw three sample faces.

  1. I then load in the Skalp materials from 3DWarehouse

  1. I click Duplicate in the List dropdown and rename the materials “Skalp Materials”. I then delete the downloaded samples and purge the Colors in Model list.

  1. I then save the model and close Sketchup. I check that the new materials list has been created:

Shot 5

  1. I then restart Sketchup, reopen the model, select Skalp Materials and then paint all three faces with each of the first three materials in the palette. Here’s the result after the third face has been painted. Note that (a) the materials are now displayed in alphabetical order but (b) Sketchup has remembered the first material from when the list was created and this takes precedence.

  1. Then I do the same thing again but with each material I set the transparency to 99% (the figure doesn’t matter but it has to be other than 100%)

Still puzzled.

1 Like

Do you get the same result with materials other than the Skalp materials?

It’s probably because the Skalp dictionary is attached to each of the materials. Attributes for their Pattern generator. You can easily get rid of those by using a simple script, check this:

get rid of the old list in your user library, first.
Then download the component again, run the script and than duplicate the list.
Or download this file:
Skalp Materials.skp (3,0 MB)

What kicked this off was when I downloaded some wood textures from the 3DWarehouse from a source called Aydon. They appear as a component which I exploded and duplicated giving the same results which I found with Skalp materials later on.

I have several material collections which I’ve downloaded from SketchupTextureClub and these give no problems at all.

Thanks Mike - I’ll give that a try and report back.

That’s cracked it Mike. I’ve tried this approach on a couple of materials collections including Skalp and it gets rid of the problem. I’ve saved the script for future use.

Many thanks for your help and guidance.

1 Like

If you install Aerilus’s Attribute inspector, you can if there is anything attached.
https://extensions.sketchup.com/extension/2c7d7254-76eb-40af-9897-bc7d16b42fb6/attribute-inspector