Trimble Connect & Sketchup Viewer

Hi All,

Just a quick question. Is it possible to allow a client to use the free sketchup viewer to open a file saved in the Trimble Connect cloud? If so how???

Yes. Select the model you’ve saved and click on the Share icon. Change the Share with field to Any users… Enter their e-mail address(es), etc. and click Share.

Screenshot - 3_23_2021 , 6_41_38 AM

Thanks Dave I will give it try.

1 Like

Hi Dave where are you selecting the file from?
I have created a new project in Connect (Connect launced via sketchup) in a new folder but I can’t find the share ? Am I in the wrong place?

How does my client find the file in the Sketchup Viewer?

I signed into trimbleconnect.com and into my folder where the file resides.

You send them an e-mail from the panel I showed in my previous post. It’ll contain a link to the file and the viewer.

Send me your e-mail in a private message and I’ll send you the link to that file so you can see from the other end.

Hi Dave,

I found the share option. I sent a link to my wife. When she opens it in Trimble Connect from the email she gets a NO Preview screen. Does she need to download the model first and then open it up in the viewer?

What browser is she using? When I follow the link it goes to the viewer and opens the file. What do you get it you follow this link?

https://app.connect.trimble.com/tc/api/2.0/s/rsJm_AF588-acqGuGIell9aV9jyfR29xDjr8wiamYBDBzHuDMHtdghYjB4OmOgiq

Hi Dave,

It opens the same window but it says working…
I will try to get a screen shot of what I get displayed


This is what I get. I am using Edge as a browser

What do you see with Chrome?

The link that you sent opens up with a plug 3D. I will try mine with Chrome.

Something missing in Edge?

The link works fine here with FF.

1 Like

There must be something wrong with the model upload. I get the same message in Chrome and when I click on the folder icon it says the model does not exist. I have just uploaded it so it does.

Which model upload? Mine?

No my model. Yours works fine

So I have deleted the model from Connect and then uploaded it again.
I have shared it and once again I get the same result in Chrome & Edge.

is there a size limit???

There might be a size limit for the browser to be able to handle it but I’m not aware of one. Try purging the unused stuff from your file and upload it again.

I have just shared a 1.8MB model and I am getting the same result in Chrome & Edge?