Tray drop downs don't drop

I’m a relatively new Sketchup user with Pro 2017 on Windows 10. Yesterday, the drop down menus for tray items are not dropping down. For example, I want to assign a component to a new layer and cannot drop down the “Layer” selector in Entity Info. This behavior is intermittent and, so far, I have not been able to isolate the cause or the resolution. Sometimes, closing all the tray dialogs will correct the problem. Other times, not even closing and re-opening the file solves the problem.

I’ve brought warehouse components into my model and I have a couple of extensions loaded. However, I’ve had the extensions for weeks without a problem.


First suggestion would be to check for correct installation of SketchUp. When you installed it, did you install it correctly by right clicking on the installer file and selecting Run as administrator? Or did you just double click on it to run it? If you did not right click and use Run as administrator, it is not installed correctly. You can repair the installation by finding the installer file, right clicking, choose Run as administrator and then choose the Repair option when it presents itself.

Thanks Dave. I believe I installed properly but just did a repair to be sure. I’ll follow-up in a couple of days to report on any changes in the interface.

No change in behavior today. After using SketchUp for hours without a glitch, the drop down menus are now frozen. Interestingly, I had another instance of SketchUp open and the drop downs functioned normally in that instance.

In the file with the problem, I have seen errors in three places: 1) When trying to update Extensions, I get the error “Failed to update Trimble Connect. Unable to read extension archive.”; 2) Under Window>Model Info, when I clicked “Fix Problems”, I saw an error that could not be fixed. I just tried this again and do not get an error now; 3) I was getting an Autosave error which I am also not seeing now.

Next steps?

I understand code but don’t know how SketchUp is built. I’m wondering if it’s possible that I loaded a poorly written Extension with a memory leak? Currently, I have Profile Builder 2 and SketchUcation Extensions installed.

Weird. The three errors are unrelated. The first one is related to the Extension Warehouse. There are at least a couple of threads on that topic already. Have a look at the forum. Having an outdated version of the Trimble Connect extension won’t make any difference to the operation of SketchUp.

The Fix Problems thing is related to problem geometry. That’s most likely due to the way you’re creating the model but if there’s nothing to fix now, then the geometry should be fine.

You could try disabling all of the extensions you have installed and see if that makes a difference with the drop down lock up issue.

you may be confusing the OS window manager and or SU login checks…

do things work with only one instance open?


John: No, the dropdowns don’t always work, even with one instance open. Also, it’s interesting that they work for a period of time, then stop working. Not sure what you mean by confusing the window manager and login checks.

Dave: I’ll disable the extensions and see what happens.


I am having the same problem with my tray menus.
The drop-down menus for materials, and for Entity info to change material types, or to change the layer of a object do not open. Instead, I see a little checkbox to the left of the name, appears when I click on the Materials drop list and nothign else happens.

I am unable to change the layers of anything that is on the wrong layer.

I can use the arrow keys to move up and down in the non-displayed drop-down lists, but this is very tedious.

It is intermittent, sometimes doesn’t happen for a long time, but when it does, no amount of Repairing, Reinstalling, Rebooting Fixes it, it will just start working again at some point.

Further, sometimes a second instance of SU will not have the problem while another will, or both will have, or none.

When you installed SketchUp did you right click on the installer and select Run as administrator? If you installed any other way it is not installed correctly and you could have problems. If you didn’t use Run as administrator or don’t know if you did, find the installer and right click on it. Choose Run as administrator and then the Repair option.

In the past problems like these described, with controls in the inspector panels, were attributed to setting display scaling higher than that supported by SketchUp on high resolution displays.

SketchUp only supports up to 150% display scaling.

So,… if you run a High DPI (resolution) display, check the Windows setting for display scaling.

Yes installed as Adminitrator, yes clean installs, yes happens on 2017 and 2018.

DanRathbun, You nailed it!

I was running an extended desktop on a larger monitor, and when the SU window is open on the larger screen, the menus do not drop, move SU back to my primary smaller screen, and it has the drop-down menus.

I tested this on a few different large monitors and it is a repeatable bug.

Though it also still happens intermittently. When I started working on a clean install today on the larger monitor I had no problems, and then just a little while ago, the menus stopped dropping down again.

Still unsure what the actual trigger of the bug is due to the intermitency.

Ah, and now that I have the SU window not maximised I am seeing that the menu is opening, but far to the right of the window, so perhaps when it is maximized it is opening the menus off screen.

Without changing any screen scaling settings, they were set to 125% on my laptop (primary), and 100% for my Ultrawide secondary monitor. I went into my Nvidia 940mx control panel > Manage 3D settings > Program Settings (tab) and adjusted specific settings for SU, specifically that when running SU “Multi-display/mixed-GPU acceleration” was changed to “Multiple display performance mode”

The drop menus are still not scaling quite right, a little distortion, but at least they show up below the field, and not off screen.

1 Like

Much appreciated Dan. Interesting solution. Makes sense because I’ve seen other intermittent UI behavior while watching demos on a large monitor.

I haven’t updated my last post because the problem ceased when I upgraded to 2018. However, since filadelfiva also has seen the problem in 2018, perhaps I also changed my display scaling when I upgraded? Regardless, I’ve had the scale set to 175% for over a month with no UI impact. When I get a bit of time, I’ll try to recreate the problem on my system at different scale settings and report back to this thread.

Thanks all.

1 Like

Well, I recreated the problem but not how I would have expected. I switched my display resolution from 175% to 150% as suggested by @DanRathbun and ran fine for one day. I then saw the problem again with dropdowns failing to drop. I’ve since switched back to 175% and have not seen the issue for 2 days now.

I’m wondering if the issue might have more to do with our specific displays & drivers. Anyway, I’ve got it working again so I’ll leave things be.

Trimble’s own words on the SketchUp Release Notes page,
SketchUp Pro 2016 and SketchUp Make 2016 chapter, Bug Fixes/Small Improvements section:

Support for High DPI Graphics

  • User may see graphics on certain Ruby Extensions that look small or low resolution, as the author for the extension may not have updated their graphics (Vector based graphics) to support High DPI yet.
  • (Win) When changing the screen resolution or scale% with multiple monitors, the monitor that is your ‘Main Display’ will be the one that controls how SketchUp will look when opened.
  • (Win) We support an unlimited number of screen resolutions, however, we currently only support a scale percentage change of up to 150%. Screen scale percentages set above 150% can result in unreadable menu items.

And again, here is Trimble’s own words on the SketchUp Hardware and Software Requirements page,
just below the Compatibility Changes section:

High DPI Support
SketchUp is DPI aware and can adjust the sizes of Icons and drawing elements so they are sized correctly for High DPI screens. Icons are sized when SketchUp starts up. If you adjust your DPI or scaling (Microsoft Windows – but only up to 150%) you will need to restart SketchUp to see correctly sized Icons and drawing elements.

Info elsewhere on the web about Windows Display Scaling:

@thayer (ping) Anything to add ?

@DanRathbun, thank you for the info. As users, when we see problems like this, it’s hard and somewhat frustrating to isolate the root cause. Since your last post, I switched back to 150% scaling and I continue to see the dropdown problem. My only “fix” for the problem is to save, close and reopen the file. So, I now see the problem fairly consistently, in multiple files, in both 2017 & 2018 SketchUp versions. I have the exact same behavior as @filadelfiva.

I also see other flaky (read intermittent) problems with SketchUp such as the program crashing on the creation of any component (only one file so far). I’m not trying to start another thread here; there are many entries about this particular problem.

My point is that we have a vastly diverse group of users and it’s highly likely that no two system configurations are alike. My file save problems are related to Google Drive. The extensions problem may have been related to one extension (haven’t seen the problem since upgrading to 2018), and this dropdown problem… who knows? NVIDIA drivers? DISPLAY memory leaks/conflicts? Not enough RAM? What I do know is that I’ve tried all the standard and recommended solutions and I still have the problem. I don’t know how to escalate this issue to Trimble so perhaps it’s time to move on.

I’m using SketchUp much more now and this causes me to think about buying a dedicated system for drawing. I wonder if starting with a clean O/S, proper video card and clean SU install will result in me having a better SU experience? Or, is the program always going to be a bit temperamental?

As a paying customer you should become aware of how to open a support ticket.

Bookmark these 2 links:

These are easily found from the bottom footer of most webpages
via the “Contact Us” link, in the rightmost “Help” column.

The more open tickets and BugSplat! reports filed per issue, the sooner they can get resolved.

The squeaky wheel gets the grease.”

Thank you Dan. Correct you are. Mea culpa, mea lazy. I haven’t felt like such a noob in a long time. :slight_smile:

It’s been a crazy busy time for me lately and I haven’t taken the time to find what you just provided. Just been heads-down focused.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.