Thumbnails not showing on .skp it show on .skb

thumbsnail not showing on the screen
i have try to reinstall and repair but not work too
i have already set on folder option and not working too
please kindly advise me please


this sometimes happens if you installed another version of sketchup that you then uninstalled.

right click on any .skp file and chose properties.
in the “open with” line, click modify and pick anything else than sketchup, for example notepad, and apply then close.

do it once more and set it back to sketchup in the suggestions, thumbnails should be back

Hi Paul, i have done with your method to change the open with as a another app default like Photoshop and get they back to sketchup again.

and ? did it fix it ?

still not working same T^T

yesterday another user had a problem with opening files that is a similar issue with windows 11 failing to maintain the link with filetypes. He managed to fix following theses steps

  • uninstall sketchup
  • open a .skp file and let windows say that no program is available to open such a file
  • restart
  • reinstall sketchup (make sure to open the installer with admin rights)

you might want to try that. Some steps may be optional

If you do a search for thumbnails you’ll find other people with the same problem.

I recently had this and it was related to having previous SketchUp versions installed but removing them did not solve the problem.

In desperation I ended up doing a windows re-install which solved it – I only have 2023 installed now.

Have you followed the support guide?
Restoring thumbnails for SketchUp files on Windows | SketchUp Help

at first time, i have doing with this link but still doesn’t work.

I have the same problem on my Mac.