SketchUp Thumbnail on File Explorer Not Showing

Hi All,
The thumbnails for my skp drawings are not showing and only the skp logo is visible. But when I checked all my drawings, only a few were showing the thumbnail. I tried searching on Google and followed instructions but it didn’t do the work. Can someone please help? Thank you

Try updating to the current version of SketchUp. Make sure it is installed correctly by right clicking on the installer and choosing Run as administrator.

How do I update to the current version? I’m using SketchUp Pro 2022 right now

Go to Download All | SketchUp and get it.

Alright, I’ll need to wait for SketchUp Pro 2023 though if it’s gonna be released. Thank you for your help though. :smile:

I don’t really get you, on the link that Dave gave, you can download - among other things - your current version (2022) and repair it, or you can download the latest 2023 version, which has also been published.

Yea I did check the link. I already tried repairing with the installer that I already have and also I need a SketchUp Pro, not just SketchUp.

For the version 2023 a new kind of installation file supplied, it is including (selectable during installation) Studio features, and for sure the Pro features too. That’s why they named it differently. So, it is including the SketchUp Pro.

Anyway there is no separate pro or non-pro version of the desktop software of SketchUp. You can see here what softwares (and services) in the four different subscription plant are included (can be used).
(I often see confusion because the name of one of the subscription plans is “SketchUp Pro” is same as the name of desktop version of the core software… :wink: )

3D Modeling Software Price Comparison | Design Tools & Features List | SketchUp

Oh okayy. Thank you for letting me know, better upgrade then. :smile: :+1:

I installed it just now, I only see SketchUp and LayOut but not Style Builder. I couldn’t even see Style Builder in the options while I was installing it. huhuhu

Style Builder should have be installed automatically. (Honestly, I did not even started it during the last 20 years :blush: )
Did you followed Dave advise?:

Hahaha yea I haven’t used it once either but you just in case I’ll need it in the future.
For Dave’s advise, am I supposed to ‘Repair’ even after installing the new version of sketchup? Cuz there are three options after clicking run as administrator; Choose Language and Features; Repair; Remove.

Yes. Use Repair.