ThruPaint is causing issues with the paint bucket tool in SketchUp!

I’ve never had this happen before, but when I activate the bucket tool in SketchUp, ThruPaint gets activated and I can’t apply a texture without ThruPaint being active. I uninstalled and re-installed SketchUp thinking there may have been a bug, then uninstalled and re-installed the rbz for Fredo Tools, but the issue continues. I have to uninstall Fredo Tools so it doesn’t interefere with SketchUp’s Paint Bucket, but this isn’t a solution, particularly when I need to use Fredo Tools. If you have any ideas why this is happening and how I can rectify this, I would greatly appreciate it. Thank you!

Go to Tools/FredoTools/Default Parameters and scroll down to Thrupaint and make sure ‘Automatically activate ThruPaint when invoking the SU native Paint Tool’ is unticked.

Thanks for your reply @Box. I have unticked that option, but it’s still popping up whenever I select the bucket tool in SketchUp. Is there anything else I can try, apart from uninstalling FredoTools? Thank you.

Ok. check the toolbar itself.

@Box that was it!! It’s now working. Thank you so much! Once again you have saved the day!!

No worries, easy to accidentally toggle it.

It’s amazing how something so small can cause issues. You certainly learn something new everyday. Thank you so much again!!!