ThomasThomassen TT Plugins not loading

I’ve uploaded to 2024 Pro, which BTW, solved much of the response problems I was having.

I’m getting an error when I attempt to install TT Solid Inspector 2 and Cleanup 3. I’m getting this error.

Strangely, they show up in the extension list, but not on any menus, either Tools or Extensions. Had similar problems with Mindsight plugins, but these rectified after I removed them, did clean install and restarted SU. I’ve tried all that with the TT extensions, but it’s not working. I need those extensions!

Did you install the tt lib file that is necessary to run any tt extensions.

Yes. Here’s how my warehouse looks.

I attempted to contact Thomas directly, but ended up on the GitHub page and frankly, I was beginning to feel like “Alice Through the Looking Glass.” Couldn’t find any direct contact information to him, but got a lot of arcane stuff on development which did not address my immediate problem.

Solid Inspector 2 and CleanUp 3 are both working fine in SU2024 for me. I used both a few minutes ago.

Were you installing from old downloads? ThomThom has recently posted new versions of many of his extensions and TT_Lib.

I don’t think so. I went to the SketchUCation site, and then looked him up separately. Are there different versions for OS and MS-DOS? I saw a file in the LIB list “Win32”. The entire program is loaded in my USERS, APPLICATIONS,SKETCHUP, PLUGINS directory.

To make sure you have the most current version of ThomThom’s extensions, get them from the Extension Warehouse. Use the included Extension Warehouse UI to install them.

I presume you mean Mac OD and Windows and no there isn’t a different version of the extensions for different operating systems.

All of the problems now appear to be solved. Turns out that SU 2024 (and other versions) loads Plugins into TWO separate and distinct Library folders. One is in ROOT/USERS/LIBRARY/APPLICATIONS SUPPORT/SKETCHUP 2024/PLUGINS. The other is ROOT/LIBRARY/APPLICATIONS SUPPORT/SKETCHUP 2024/PLUGINS. Notice any diffference? One Library sits at the ROOT level and the other sits one layer deeper at ROOT/USERS level. When I was instructured to go and removed all the plugins that were not behaving well, I was instructed to remove them from the USERS level folder, not knowing that there was another one lurking. So each time I opened SU and went to the Extensions Manager, the bad actors were still there, non-functioning and unable to uninstall.

Spent almost an hour on the phone with Tim Wells, an SU tech support fellow in Denver, and he was flummoxed (as was I). We downloaded a fresh SU 2024, and it opened with the same load of plugins even though we hadn’t instlaled any. He suspected that there were coming from somewhere else. He was going to check with one of their more Apple-savvy techs and get back to me.

Meanwhile, I contacted my brillaint Apple-guru daughter in law and she said that some Windows-based packages ported for MAC, sometimes create mulitple libraries. Yup! She said go up to the Root directory and check there. Sure enough, another Library with duplicates of every SU 2024 file. I erased the bad actors from both libraries and reinstalled their Ruby files in the manager and Voila! Everything was working as it should. Problem solved.

So… if I’m not the only one, make sure you delete files from both libraries in Mac Sonoma.

All extensions that are installed by the user should go into ~/User/Libray/Application Support/SketchUp/SketchUp 2024/SketchUp/Plugins. That’s where Install Extension in Extension Manager will install them.

1 Like