Can't install certain Extensions

Having a hard time installing extensions either through the Extension Warehouse and Extension Manager by downloading and trying individually. Some have gotten loaded, but I cannot get fundamental extensions that I use regularly to load…

I have reinstalled SketchUp as an Administrator to no avail… still getting messages like this:

Heeeellllppppp

Click on the gear icon at the top right corner of Extension Manager. To what do you have the loading policy set?

It says Unrestricted, Dave.

BTW, isn’t it Friday for you and you should be doing something else? :sweat_smile:

Yeah. It is Friday and I should be doing something else but I’m a glutton for punishment. :smiley:

1 Like

FWIW it does say that Material replacer is compatible with 2022 but doesn’t list 2023 or 2024. It may not work in 2024. There were changes to Ruby for SU2024 that broke a lot of old extensions. Do you have the current version of the required TT_Lib2 installed?

That’s probably he issue, Dave…

Interestingly enough, I have tried to install Sketchucation’s extension with a problem loading the TT_Lib2. It keeps kicking it back to Disabled:

We might be getting closer, Detective.

What happens if you enable? And what happens if you install TT_Lib with the Extension Warehouse instead?

Edit to add: I got a change to install Material Replacer in SU2024 on my PC. It does work fine for me so I have to wonder what’s up with your computer.

You wrote:

Does that mean you right clicked on the installer and chose Run as administrator whil being logged into Windows under your normal Windows login?

So, when I try to push it to the Enable column, it waits a sec and then goes back to Disabled side (kind of like me when I am forced to be around my wife’s family) :upside_down_face:

I will try to unistall TT_Lib and go through the EW. Gimme a sec…

:crazy_face: :rofl:

Try a cold reboot of the machine too.

Nope. Sketchucation still shows the TT_Lib in the Disabled column. I am going to uninstall/reinstall Sketchucation again to see if there is a remnant of something hanging around. Really appreciate the help, Dave.

I don’t thing uninstalling and reinstalling the Sketchucation ExtensionStore will help. I would go into the User Plugins folder and delete the files for TT_Lib2 and Material Replacer. Then restart SketchUpa nd try to install both of those directly from the Extension Warehouse stating with TT_Lib2.

BTW, isn’t it even more Friday where you are?

It’s verrry Friday here in Louisville, but the bourbon helps :+1:

OK, reinstalled Sketchucation, after a full delete of any and all of the TT_Lib2 files…

Interesting when I opened SketchUp it popped up a message from the “core.rb” needing to reinstall TT_Lib.

Still doesn’t work right on my brand spankin’ new Razer Blade 16, but I think we are getting closer. Full disclosure, I did drag/drop extensions into the usual path. Mayyybe thats the problem.

1 Like

I’d blame that before the bourbon.

Check your PMs.

To everyone out there like me… Dave helped me arrive at the answer that drag/dropping old files and their folders into the new path is not the way to go. I completely reinstalled SketchUp and went through and loaded in extensions one by one. Everything works!

Dave did mention that Sketchucation does have a way to load in “bundles” that will take away some of the manual labor, but I really do think this feature has to be better integrated into base SketchUp for power users with tons of extensions.

Thanks again for the help, Dave!

2 Likes