SketchUp 2018 Extension Warehouse bug preventing me from installing extensions

bug

#1

I am currently unable to install on SketchUp 2018 any of the extensions that I use on a daily basis. This seems to be because SketchUp thinks they are already installed. They are not. The list of Installed extensions in the My Extension page of the Warehouse does not match the actually installed extensions show in the Extension Manager. However, since SketchUp thinks they are installed, I am only shown an “uninstall” button—which doesn’t work because they aren’t actually there, so I just get an error: “The extension could not be uninstalled for an unknown reason.”

This is not a 2018 compatibility issue… most of the extensions are listed under Compatible Extensions, SketchUp simply thinks they are already installed when they are not. It seems to be a bug with the Extension Warehouse itself, and I see no way to refresh or resync what extensions it thinks are installed versus the ones that are actually installed.

Is there any way to completely empty the My Extensions list or to force install extensions from the warehouse?


Thom Thom plugin problem
#2

Have you tried signing out and back in from within sketchup. Icon bottom left.


#3

I am having the same problem, I installed 2018 on my laptop yesterday, it is acting like all of my extensions are load for 2018 but they are not. My only option when I go to try and upload them individually is to uninstall.

I load 2018 a few weeks ago on my tower and did not have this problem at all.

The only difference in the install was that I loaded some extensions on the tower before I licensed it yesterday I put my license in right after loading it.

This morning when I tried signing in and out to see if that worked, a strange thing happened right after I signed out someone else name came up in the name box.


#4

Yes, I signed out and signed back in. I also uninstalled all copies of SketchUp from my machine and did a fresh install of 2018. No luck.


#5

Just a update I see that Soap Bubble was load into 2018, This is an extension that I have removed quite some time ago but it was still in my list of all extensions. But it was not in 2017 so it loaded.

I see that Soap Skin and Bubble has a mention on here about a software rebuild?


#6

Yes, I am having the same issue. In particular, I really need to use Profile Builder 2, which I previously purchased for Sketchup 2017.


#7

Same thing happening to me, stuck in the middle. The extension I want won’t show up, but I can’t uninstall it. It doesn’t exist on my computer yet the extension warehouse thinks it does.

I get the error "Can’t uninstall for an unknown reason’ whenever I try.
god dammit.


#8

I have signed in to the extension manager, but there is no button to find my 2017 Pro extensions and plugins


#9

Not the extensions manager, the Extension Warehouse.
Go Window/Extension Warehouse and in the top right of the window that opens should be your username if you are signed in correctly. This has a drop down menu when you hover over it, select My Extensions.


#10

thank you, Box, extremely helpful, it worked, many plugins are again available or seem to be
but now I have to again reorganise all plugins and extensions around my screen, plus all settings like my standard menu’s, small icons in stead of large ones, etc…


#11

The title says Extension Manager bug. If I get this right it’s an issue with the Extension Warehouse. Am I correct?

I don’t have a solution but correcting the thread title would make it easier for others, both users and SketchUp staff, to understand the issue.


#12

For those of you still having problem, perhaps clearing the cache on Internet Explorer or Safari depending on your OS.
Even if you don’t use them by default, sketchup does use them.


#13

Sure, the Manager and the Warehouse are mismatched. But if it seems more a Warehouse issue, I’ve updated the title. Hopefully that will increase visibility of this issue.

I did a work-around by downloading RBZ files and installing them directly, but that won’t work for plugins purchased through SketchUp. I am currently running a few different “trial” periods and hope I can resolve this issue before they run out. I would love to be able to access the products I purchased already.


#14

Clearing the Cache Worked for me. Thank you Box !


#15

Extension Warehouse had some hickups this week. Should be resolved now.
Please report back if problem persists.


#16

Cleared my cache and removed the trial licenses from the paid plugins, and it seems to be working now. Thanks for the update.


#17

I’m having this problem also. Cleared cache on both my browsers (mac) and same prompt when I try to uninstall extension via Manager and Warehouse.

“The extension could not be uninstalled for an unknown reason.”

Please let me know if there’s anything else to try.

Thanks


#18

Which extension is this?


#19

It’s a few old ones.

Camera Tools
Dynamic Components
Sandbox Tools
Trimble Connect (shows up, but it’s uninstalled)

I haven’t used Sketchup in a while so I assume it’s from really old builds. I don’t know if that ha anything to do with it. They all have updates though. I’ve updated and tried to uninstall again, but same result.


#20

Those are all ‘built in’ extensions. If you were able to uninstall them, I think they’d get installed again the next time you started SU.