Can't install any extension/plugin from warehouse

I had 2015 Pro and after uninstalling 2015 and installing 2016 Pro… I cannot install any extensions from the warehouse. This is very disappointing since not only is there no option to simply update our 2015 to 2016 without uninstalling, I now can’t set up my tool-set the same way.

I tried signing in and out multiple times and even freshly installed Sketchup 2016 again but I keep getting this error.
I would greatly appreciate any assistance.

Why don’t they create updates you can download to “patch a 2015 build to 2016”?

I believe it’s a glitch in the server that a few people reported last night,

@Barry asked earlier for reports of anyone still having the issue…


(Moved to the Extension Warehouse category.)

It is a server-side error. Nothing any customers can do about it.

See the following and other topics in the Extension Warehouse category:
AJAX Error when downloading from Extension Warehouse

Offtopic gripes regarding installation:

[quote=“Rick, post:1, topic:24412”]
I had 2015 Pro and after uninstalling 2015 and installing 2016 Pro …

This is very disappointing since not only is there no option to simply update our 2015 to 2016 without uninstalling …[/quote]

First of all, there is no rule nor law, that requires you to uninstall v2015 before installing v2016. There never has been. They install into different directories (unless y’all change the install directory manually ? … which is not a good idea, ever.)

The corporate network licenses give a 30-day grace period for you to migrate your plugins and usage over to newer versions after an upgrade.

So you should be able to reinstall 2015 Pro, and reapply the old 2015 license, so you can work with your “tool set.”

[quote=“Rick, post:1, topic:24412”]
This is very disappointing since not only is there no option to simply update our 2015 to 2016 without uninstalling …[/quote]

Where did you get this idea ?

You have two options.

(1) You can install extensions (or some of them) from the SketchUcation PluginStore,

(2) … or you can copy over your extensions from the v2015 plugins folder. Since they all work for Ruby 2.0, and if you had kept them up to date, the majority of them should work OK.

  • Uninstalling SketchUp 2015 should NOT have removed your “Plugins” folder in the %AppData% path for SketchUp 2015.

  • You should do one at a time, and then start SketchUp to make sure it works ok…then close SketchUp, and repeat.

  • You should check the version number for the SketchUp team extensions beginning with “su_”, if the ones distributed with v2016 are newer, do not copy and overwrite them with older versions from v2015.

… or, you can just be patient and wait until Monday, and hopefully it will be fixed.

We have the same issue flaring up tonight, and we’re in communication with our hosting provider to fix it. I appreciate your posts to help us identify and respond quickly. Frustrating, I know, but it’s going to get better.

1 Like

I think we miss understand each other, but I appreciate you taking the time to explain everything to me.

The directions from Sketchup itself on how to get Sketchup Pro 2016 is to uninstall previous versions. I did leave 2015 on my PC when I installed 2016 but when I got the error, I assumed it was because of the old version.

Secondly, please tell me how do you patch/upgrade a a copy of 2015 to 2016 because I have never seen any information that this can be done or how to do it. The only thing that I could ever see is that if you need to use the latest version of Sketchup, (which is necessary if you use any file created with newer versions), you have to download the complete newest build. If there is a way to “patch” or upgrade an installed version of Sketchup to a newer one, I did fail to find this.

I assume you simply type in the new license into the older version and it will automatically patch the copy of Sketchup? If this is true, they don’t advertise it all. So my suggestion would be to add a “upgrade” link on the “all downloads” page so that customers will know they can upgrade their copy without installing from scratch.

My apologies for being confused on this, I have never had this confusion with any other software before.

Where did you find this instruction, Rick? I’ve never seen it and never uninstalled an old version before installing a new one. This computer still has SU2015 Pro on it. My previous PC has SU8 Pro, SU2013 Pro, SU2014 Pro, and SU2015 Pro installed on it. They all work, too.

Each version of SketchUp installs as a separate version. A new version does not overwrite, patch, or upgrade an older one.

Except that’s not the way it works at all. Since each version installs separately, the older version doesn’t get touched by installing the newer version. The license for SU2016 only works on SketchUp 2016. It will not work in SU2015 or any other earlier version. In the same way that the license for an earlier version does not work in SU2016.

1 Like

Because …

The solution is simple. Stop making assumptions. Read the instructions, and when you cannot find them, or do not understand them, come here and ask. We are happy to answer.

You cannot find them, because patches do not exist, and no one should ever said that they do.

The SketchUp development team has never released patches (ie .msp files,) at least since 7.0 when I first started with SketchUp, (and that is like 8 years or more.)

You update a particular version of SketchUp to a later maintenance release (MR,) but still the same major version, by downloading and running the full installer (for the MR) per any instructions given. Most the time, you just install over the top of the old release. Occasionally they will ask us to clean out old team authored plugins, or rarely temporarily remove the license, and uninstall the old release before installing the newer maintenance release.

The word upgrade applies to your license not the application. So you upgrade your rights to run newer versions of SketchUp.*

(* Yes, I know we booboo sometimes on the forum, and use the word “upgrade” incorrectly.)

1 Like

We just changed a configuration, and we hope this fixes the intermittent problems we’ve been having. Let us know if it is not fixed for you.

I just tested it on my computer at home and it works for me.