TT_Lib + SU2017 Pro Issues


#1

Recently updated to Sketchup 2017 Pro and attempted to bring over my plugins from Sketchup 2016 Pro. All the plugins have transferred except for the beloved ThomThom TT_Lib and the associated plugins. I’ve tried downloading the Latest version of TT_Lib, 2.10.6, however the plugin does not get updated and Sketchup still kicks back a “Download the latest TT_Lib plugin” message.

Even when I attempt to download the plugins directly from the extension warehouse, the plugin installation does not stick. Before I tried this method, I uninstalled and reinstalled sketchup to ensure there would be no interference with “outdated plugins”

There may be some issue with the extension signatures / securities policies as well. Despite my plugin settings being set to “unrestricted”, Sketchup is not allowing the plugin to run.

Any insight on the matter would be greatly appreciated.


#2

This is most likely your problem. You should always install fresh instead of copying from an older version. Go to the Plugins folder, delete anything related to TT_Lib and then reinstall from the EW.


#3

Thanks for the quick reply Dave.

I tried running the plugin install on a clean “untouched” version of sketchup and the issue still persisted.

This is the “Load Errors” dialog box if it helps.
Error Loading File C:/Users/rkrauszer/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/tt_cleanup/bootstrap.rb
Error: #<NameError: uninitialized constant TT::GUI>
C:/Users/rkrauszer/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/TT_CleanUp/core.rb:54:in <module:CleanUp>' C:/Users/rkrauszer/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/TT_CleanUp/core.rb:33:in<top (required)>‘
C:/Program Files/SketchUp/SketchUp 2017/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:45:in require' C:/Program Files/SketchUp/SketchUp 2017/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:45:inrequire’
C:/Users/rkrauszer/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/tt_cleanup/bootstrap.rb:35:in <top (required)>' C:/Program Files/SketchUp/SketchUp 2017/Tools/extensions.rb:197:inrequire’
C:/Program Files/SketchUp/SketchUp 2017/Tools/extensions.rb:197:in load' C:/Users/rkrauszer/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/tt_cleanup.rb:40:inregister_extension’
C:/Users/rkrauszer/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/tt_cleanup.rb:40:in <module:CleanUp>' C:/Users/rkrauszer/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/tt_cleanup.rb:15:inmodule:Plugins
C:/Users/rkrauszer/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/tt_cleanup.rb:14:in <module:TT>' C:/Users/rkrauszer/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/tt_cleanup.rb:13:in<top (required)>’


#4

Could you please precede and follow your error listing with lines starting with a triple backtick (```) so that the forum software doesn’t reformat it? As is, the actual error message has been chopped off the line starting with “Error: #”!

When you did the install on a clean SketchUp, did you do it via the EW or sketchUcation plugin store internal to SketchUp, or from .rbz files you obtained in some other way? The line numbers in your error report don’t make sense when compared to the files I have installed on my SU 2017, which makes me wonder if you have a mishmash of latest and older versions.


#5

The problem isn’t that SU somehow has been touched by plugins but that SU changes each release and some plugins has to be updated to work in the new SU version.

If you install the new, updated, plugins it should work.


#6

One additional thought: if you uninstall then reinstall SketchUp, that does not clean out your installed Extensions. Likewise, the loader from the EW does not purge an extension’s folder before writing in new files. It is possible to get a mixture of old and new if you don’t purge the Plugins folder manually.


#7

Thanks SLBaum and Eneroth,

With a clean install, there is nothing in the plugins folders except for the default sketchup extensions. When I try and download the latest TTLib from the EW via “extensions warehouse” within sketchup, the installation of TT_Lib 2.10.6 does not “stay installed”.

When I open sketchup again, I receive a warning that TT_Lib is not installed. Then I go to the extension warehouse (via Window -> Extension Warehouse) to download the TT_Lib 2.10.6, it says it’s already installed, but Sketchup does not recognize it’s installed.

// See below for error window screen clip //

Would there be an issue if I have different versions of SketchUp isntalled? I have 2016 and 2017 installed now, but they are routed to different folders. “Sketchup 2016” and “Sketchup 2017” each with their own separate plugin paths.


#8

The undefined constant TT::GUI comes from TTLib, so it certainly seems like it is not installed properly. But at this point I have no clue why, sorry! Sounds like you need help from @thomthom himself…

Each version of SketchUp installs into completely separate folders, so except if extensions put contents into their own non-standard places (which TT does not do) there is no way for plugins from one version to interfere with those of another version.


#9

Do you see TT_Lib2 files in your Plugins folder as you install?

How does the content of your Plugins folder look like?

If you open the Ruby Console, then enter $LOADED_FEATURES - what is the output?


#10

Thanks for your help SLBaum, this is definitely a puzzling issue!

ThomThom,
TT_Lib2.rb, and TT_Lib2 folders exist after install

As a test, I’m attempting to load up Edge Tools^2. tt_edgetools.rb and tt_edgetools directory exist in the plugins folder

See below:

This is the result of the $LOADED_FEATURES ruby console entry:
Ruby Console LOADED FEATURES - 2016-11-17.txt (11.2 KB)


#11

Is Edge Tools loading? But not CleanUp?

Can you copy+paste the full error message you get when loading? (From what I understand you experience load errors as well?)


#12

Also, what is your Extension Security settings?

And while it should not matter (I think) is TT_Lib enabled in the Extension Manager? Can you show a screenshot of that dialog?


#13

That $LOADED_FEATURES report seem to indicate that only a handful of files from TT_Lib got loaded, then it stopped for some reason. Getting the full error log would be helpful.


#14

ThomThom, thanks for the help.

For this test, I’m only trying to load TT_Lib and Edge Tools to make it simpler to debug.
I’ve attached a screenshot of the expanded error mesages, the extension manager window with security settings set to unrestricted, the “TT_Lib^2 Not Installed” as well as the plugins folder and the TT_Lib folder.

Let me know if I can provide anything else. The .txt file i uploaded earlier was the full report from the $LOADED_FEATURES ruby script.

Just ran the $LOADED_FEATURES script again. Attached here:
$LOADED_FEATURES -2016-11-17 5pm.txt (15.2 KB)

Thanks again for your help


#15

Hm… ok. The TT_Lib dialog appear from Edge Tools because there is a LoadError when loading TTLib This is typically when the library isn’t installed. But in this case it’s propagated from an internal load error in TT_Lib.

But we are missing the actual error here. If you where to remove Edge Tools and leave TT_Lib in place - do you then get another error?

If not, can you try this in the Ruby Console: load 'TT_Lib2/core.rb'


#16

Deleted Edge Tools from the plugin directory, leaving just the TT_Lib in the plugins folder and received this error message when opening SKP2017:
Error Log - TT_Lib - 2016-11-18.txt (1.7 KB)


#17

When I type: load 'TT_Lib2/core.rb’
I get this report:
Error Log - TTRuby Console for TTLib Core.txt (35.6 KB)


#18

Huh! that’s odd…

Error: #<LoadError: cannot load such file -- C:/Users/rkrauszer/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/TT_Lib2/libraries/2.10.6/2.2/win64/tt_lib2>
C:/Program Files/SketchUp/SketchUp 2017/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:45:in `require'
C:/Program Files/SketchUp/SketchUp 2017/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:45:in `require'
C:/Users/rkrauszer/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/TT_Lib2/bezier.rb:13:in `<top (required)>'
C:/Program Files/SketchUp/SketchUp 2017/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:45:in `require'
C:/Program Files/SketchUp/SketchUp 2017/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:45:in `require'
C:/Users/rkrauszer/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/TT_Lib2/core.rb:503:in `block in <top (required)>'
C:/Users/rkrauszer/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/TT_Lib2/core.rb:498:in `each'
C:/Users/rkrauszer/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/TT_Lib2/core.rb:498:in `<top (required)>'
<main>:in `load'
<main>:in `<main>'
SketchUp:1:in `eval'

Can you check this directory? C:/Users/rkrauszer/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/TT_Lib2/libraries/2.10.6/2.2/win64

Does it have any files?


#19

If you want we can try a TeamViewer session?


#20

Thom,

I sent you an e-mail via your website. The TeamViewer may be necessary.

This is my “libraries” plugin

-Rob