ThomThom plugins not showing up

SketchUp has made a complete mayhem with ThomThom’s plugins!
I have: Component Replacer, Pick It, Rotate & Scale and CleanUp installed and enabled, but I cannot use any of them. After years of usage, they recently completely disappeared from the UI menu. Only CleanUp shows up under Extensions dropdown menu, but it doesn’t have any submenus, while it’s supposed to have. The other plugins should show up in Tools menu, but they don’t.
I cannot assign any shortcuts to these plugins, because they are not listed in Preferences. It looks as if they are not installed, but they ARE installed and enabled. There are no errors at SketchUp launch.
I did some plugin cleanup recently, and I might have messed something. But. I uninstalled all four ThomThom’s plugins along with TT Library. Then installed again: first TT library, and then the plugins. After each step, I restarted SketchUp to make sure everything “clicks”. AFAIK, TT Lib is the only necessary dependency for these plugins. I used to have version 2.12.0, then installed the new 2.12.2 (updated for SU 2021), but it made no change. I tried that in SketchUp 2020 and 2021. Same problem.
What can I do?

Have you changed the Extension Loading Policy in the Extensions Manager (top right, gear icon) ?

You could try to repair the SketchUp install. With SketchUp closed, find the downloaded installer executable, right-click it and choose “Run as administrator” from the context menu. Then choose the Repair option.

Are these the proper settings?
I’ll try repairing SketchUp installment in a minute.

Repairing SketchUp did not help :frowning:

Unrestricted Loading Policy is best with the extensions you have installed.
Advanced Camera Tools is a Shipped-Extension, it is signed, so something is adrift because your Extension Manager says it’s Unsigned.
The latest version of my 2dTools is Signed - yours says Outdated Signature !
Have you repaired your installation then reinstalled the extensions properly from their RBZ ?
The Shipped-Extensions should auto-copy across from their folder…

Clearly something is wrong with your whole setup…
I take it that this applies to v2020 - as your profile ?
Version 2021 is much the same in any case…

When you say the Repair did not help, did you restart SketchUp [which version] afterwards etc ??
Have you tried an Uninstall and then a Re-install [always using Run as administrator ?]

Yes for using any unsigned extensons.

However, Trimble’s Advanced Camera Tools extension should be signed.
There is something not right there.

Did you copy plugins from an older install ?
Or did you reinstall all plugins ?

Yes, I did copy the installed plugins from SU 2020 to 2021 plugins folder. I know it’s not the recommended way of doing things, but it’s been all working fine for years, till now. Even in SU 2020 I have this problem only now, almost a year after its installation.

At the moment I sent SketchUp to hell, and during the uninstallation this popped up:


I don’t know if I should worry about that. The uninstaller said that it completed successfully. Of course, I have shut down SketchUp first. Now I’ll reboot my PC, reinstall SU and check up.

You will have to go and empty the folder where you copied the extensions yourself. The SketchUp uninstaller, AFAIK, removes only the files that belong to the installation package.

Here’s what I did:
I reinstalled SketchUp 2021 - removed it, restarted PC, manually removed all remaining files in AppData folder, then installed again with “Run as admin”.
I manually installed all my plugins from ThomThom, starting from the new, updated version of TT Lib.
They work.
Then I took all the plugins I had in my SU 2020 plugins folder, besides files regarding ThomThom plugins, and copied them to SU 2021 plugins folder.
Now ThomThom plugins don’t work any more. They are not present under Tools or Extensions tab. They will work again if I remove all the other plugins that I pasted.
Seems that there is something that “overrides” ThomThom’s plugins and hides them from me.
Of course, I will now start installing all my old plugins manually from my backed up RBZ files, but it will take ages and dozens of SU relaunches to get to know the culprit. It happened recently, so I might blame the new plugins that I installed. I’ll start from Curic Recall Command.
I’m posting the full list of plugins I have installed in SU 2020 - besides ThomThom’s plugins. Maybe you’ll have any idea who’s the criminal…

I just realized that some other plugins don’t work either, e.g. Faces To Groups. It only has options in its Extensions list, but no command to launch the script.
What the hell has happened…
It doesn’t work in SU 2020, even after repairing sketchup installation and reinstalling the plugin.
It does work in SU 2021 if I just install it.
It does work if I only copy the single RB file from 2020 plugins folder to 2021 plugins folder.
But like half of the plugins don’t work if I copy my whole plugin repo from 2020 to 2021.
I don’t have time to manually install all of my plugins again…

This is the only recommended way, so maybe you’ll have to make time…

1 Like

Okay, I already know the answer, more less.
Seems I was right.
In fact it wasn’t the fault of me copying plugins. I knew I could do it with no harm, and no repair installation was needed.

The Curic Recall Command plugin makes some terrible havoc with plugins in SketchUp 2020.
Until I install it, everything works just fine. When I install it, lots of plugins disappear from my dropdowm menus (despite being installed and enabled in extension manager), thus they become unusable. ThomThom’s plugins seem to be particularly vulnerable.
I only need to remove Curic Recall Command and restart SketchUp to bring things back into order.

What’s really interesting, I don’t have any problem now in SU 2021.

1 Like