This does not appear to be a Sketchup model

I am having trouble opening several Sketchup files that were created back in 2016. I keep receiving a pop saying “This does not appear to be a Sketchup model!” Not to sure what the issue might be. The files are on a disk and have copied them over to my desk top and tried opening them but keep getting the same message. If anyone has any suggestions please let me know. Thank you

What is the file extension?

The extension is .skp

Can you share the file? There is really no way to identify the issue without taking a look.

Aaron, Here is the file. https://arcadiso365-my.sharepoint.com/:u:/g/personal/ozzy_manzo_crtkl_com/Ee9jyap1-JNJvAaVdSBKnG4BGJh6BORj2HyOJi28WHMflA?e=W1D00V

Can you upload the model through the forum? Many people here are hesitant to download from third party sites.

It is the seventh button from the left (little rectangle with an up arrow above).

The file is too large that’s why I sent a link to it.

It’s 100Mb plus.
Probably sloppy purging.
BUT it won’t open in SketchUp - so it’s not a SKP file…
I haven’t extracted the first block of bytes, but I suspect there’s something incurably corrupted in the file.
Sorry :worried:

1 Like

Thanks TIG!

No idea how it might have happened, but the file I downloaded from your link is just a great mass of zero’s. Definitely not a valid file of any useful type!

1 Like

I lost a collection of sketchup files and person models years ago 2013 ago. My son found them on a thumb drive (he used windows to recover it), I’ve tried opening them on versions 7, 8, 2011, 2015, 2017 and a trial of 2020. I’ve tried importing and opening in every version of sketchup I have and no luck. Any help would be awesome. I saw in earlier posts extracting some code to check and elsewhere uploading the file…

Could you reply and attach the smallest file that fails?

daffodil.skp (4.9 MB)

this is one of the smallest I think the biggest file is 48mb

daffodil.skp (4.9 MB)

I looked at the file with a hex editor, and large chunks of it is filled with zeros. Also the parts at the start and end of the file don’t look like normal SketchUp files. I’m not sure how it got into that state, but it’s nothing like a SketchUp file at this point.

thanks for looking. is there any source I can use to identify and help trouble shoot this myself. I looked at a few files through notepad after reading your reply and it looked like when the drive was restored the code was mixed with an audiobook like it needed to be defragged before copied off the drive. sad day.

I hadn’t seen the zeros in a file before. I used a hex editor program to compare your file against a normal file.

I have no idea what could cause it, but I’ve seen a “dead” SketchUp file full of zeros once before from a different user.