'This does not appear to be a sketchup file'

Hi all,

been scouring for a way to resolve this but to no luck.

worked on a file in October 2023, and tried opening it today to ‘file not found or invalid’
when I try alternatives such as opening via SketchUp make it says the file does not appear to be a SketchUp file, not sure if I’m missing something obvious…

I have been using a different Trimble account since the creation of the original file but would not have thought that would have been the issue

any help would be greatly appreciated!
thanks in advance,

Patrick

link - WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free

We’re you working from an external device, the cloud or fro your internal storage device SSD or HDD?

External Lacie drive

Thanks

I’m going to check your file in a minute but there’s a high probability that it’s corrupted.

I tried to get something out of the file, but didn’t succeed. Look in the same folder to see if there is another file with the same name, but has a ~ at the end. That would be the backup file, and maybe it’s in better condition.

Unfortunately, there is no backup, does that mean its lost? if so how would I avoid this happening again

It would appear so unfortunately.

Don’t work directly on files saved externally. Save the file to the internal drive while you are working on it and only copy the saved file to the external drive when you are done for the time being. Copy it back from the external drive to the internal drive before opening the file again in SketchUp.

If you need to make the file portable, publish it to your Trimble Connect storage in addition to saving it on the internal drive.