"ceci ne semble pas être un fichier sketchup" "this does not seem to be a sketchup file"

I was working on a file yesterday without any problem
This morning when I tried to open it, Sketchup does not recognize the file
I tried to “repair” sketchup but it still does not work
Other files that I have on my laptop work

Can someone help me ?
Thanks a lot

Share the file and we can try to help. Without it there’s nothing at all we can do.

Thank you, here is the file on a wetransfer because it is too big to send on this

Unfortunately that file is full of zeroes and there’s nothing to recover.

Your forum profile is not correctly filled out. Are you using Windows? If so, can you share the .skb version of the file?

Please also correct your forum profile. SketchUp for Schools is a web-based version of SketchUp available to primary schools. Is that what you are using or are you using SketchUp Pro? Please put in the computer’s operating system and graphics card model number.

I don’t understand because it worked perfectly yesterday and even this morning, then i turned off and on my laptop and since then the file is not working.
I am using Windows yes
I am using Sketchup 2023 with a student license that i paid

I don’t manage to send the SKB file
This file was on a Google Drive and I was working directly from there, I don’t know if that is an important information

I’m afraid I don’t know what happened to your file to result in it becoming so badly corrupted. It might have to do with powering the computer off while SketchUp was trying to save. I don’t know. The SketchUp developers have seen a number of cases of this and have been trying to identify why it happens.

It could be important. There’s plenty of anecdotal evidence to show that working on files directly saved to the cloud seems to be risky. The best advice is to save files to your computer’s internal drive and sync to Google Drive if you need to make them available remotely.

Please put that, along with the version of Windows in your profile.

Then you are using SketchUp Pro, not SketchUp for Schools. Please correct that.

The information in your profile helps us help you but only if it is the correct information.

What do you mean? Is there no .skb file or could you not upload it to We Transfer?

Can not upload it on wetransfer for some reason

Try changing the file extension to .skp Make it read your filenameskb.skp.

Thank you, it does not change anything, still impossible to open it
When i turned oof my laptop, I made sure sketchup was off, I really dont understand what happned

I was asking you to share the .skb file with me so I could try to see if it is a viable file or not.

SketchUp might have been shut down but Google Drive may still have been working.

I’m sorry but tt this point I expect you will need to start over on your file. This time save it into a folder on your internal drive. Copy it to Google Drive if you want. Or publish your file to Trimble Connect if you need a copy of it saved to the cloud.

And again, please update your forum profile.

File is uploading on wetransfer very slowly (1 to 2 hours waiting)

It shouldn’t take any longer than the previous file you shared. Is your internet connection bad? Try uploading to DropBox instead.

my internet is not so good so i will do it when i have a better connection, thank you

This may be the cause of your problem. Another reason to just save your files to the internal drive on your computer.

Google drive offers a version history - why not go back and get a version of the file from before it was corrupt?