The Template .DAT file is missing!

Everytime I open SketchUp 2018 I get reminded that the template .DAT file is missing.
Its not in this folder which is where I expect it to be,
C:\Users\Gary Arnold\AppData\Roaming\SketchUp\SketchUp 2018\SketchUp\Templates\

Does anyone know where this file is?

Interesting. I’ve looked through the various directories for SketchUp 2018 and don’t find a template.dat file at all and I don’t get that error message when I open SU2018. Is it possible that is coming from an extension?

Do you still have the installer for SU2018? You might try repairing the installation by right clicking on it, selecting Run as administrator and then Repair when the option is presented.

no i dont have the installation files. I installed it directly from the trimble site.
I’ve also noticed Trimble have removed this version from their downloads so I cant get the install files from there.
Is there another solution?

You can get the installer from this archive…

I found the installation files for Sketchup 2018! I did some digging and notice that this was an issue in 2020! I done a repair as you suggested but guess what…it hasnt fixed the problem!
All I can think to do is uninstall it and start from scratch but Im hoping this wont cause more issues with my vray and pdf plugins but I bet it will!!!

FWIW, I have no .DAT file in my Templates subfolder either ??

I have reinstalled sketchup 2018 but still the same message,

One or more of your preferred File Location paths are invalid,
Please correct this by going to Skethcups Preferences - Files and specify a valid path for any items shown in red.’

The Templates file location is shown in red but I dont know where a valid path is.

Unless anyone knows I will have to keep ignoring this issue- its like an annoying fly buzzing around!

Did you reinstall it as I said by right clicking on the installer and choosing Run as administrator?

The correct location should be C:\Users\YourUserName\AppData\Roaming\SketchUp\SketchUp 2021\SketchUp\Templates\ It’s not a path that you can edit, however.

Yes, I have reinstalled it as administrator and I have repaired it as administrator.
I have also checked the file path which is as below but it is still highlighted in red!!

C:\Users\my name\AppData\Roaming\SketchUp\SketchUp 2018\SketchUp\Templates\

Do you have a folder there ?
C:\Users\my name\AppData\Roaming\SketchUp\SketchUp 2018\SketchUp\Templates\

Does have FULL security permissions set for all entries under Properties ?

Tried that and the folder keep reverting back to Read only.
I did some reading and Windows 10 is suspectible to folder permissions reverting back.
I checked my folder permissions and I am the Adminstrator and I have Full Control.
I tried turning Read Only off on the C drive properties and directly in the Template folder properties but the problem remains even after I have restarted the computer and reopended sketchup.
I have not idea what is causing this problem

Select the folder’s icon.
Right-click > context-menu > Properties > Security
Edit all entry so they have FULL Control permissions ticked.
Apply and OK…

The Properties front-most dialog page will say Read-Only and revert, but this is not directly connected to the Security settings…

I can confirm that the problem is not being caused by the folder permissions. I have Full Control.
The preferred File location path for the Templates remains invalid.


We have had these issues as well when trying to duplicate Private and Shared Preference json files for our training center.
The only way you can get rid of it is by deleting these or editing.
The shared is in the Roaming, the Private is in the Local User data (or vice versa, I never understood the logic)

Look for these files:
SharedPreferences.json and PrivatePreference.json

We now use Trimble Connect for this, btw.

I didn’t say to ensure that YOU hade FULL Control persmissions - but, that ALL those listed in the Edit dialog had that setting individually…

Clearly SketchUp is failing to read the Templates folder, that’s not ‘you’, but SketchUp itself…

Thank you so much Mike. This has fixed the problem. Great job!

Thank you for your help. The problem has been fixed by deleting the SharedPreferences.json and PrivatePreference.json files.