The renaming of Groups selected in Outliner is insane

I think the issue of Outliner renaming my ‘groups’ when a multiple selection is made is intolerable.
The workaround is obvious; ‘STOP selecting multiples in Outliner’ I hear, but my muscle memory is excluding the obvious as an option. I am wasting so much time with this; the naming of Groups is fundamental to my workflow.

I’m just wondering if any in the SU community is bothered by this new feature and does anyone have an inkling about Trimble’s attitude to the issue.

1 Like

Hi Willo. I use 2022 where Outliner acts as I would expect it to regarding Group naming. Are you describing a new bug in 2023? Cheers, Kevin

Like you, my workflow totally depends on using named groups in the Outliner so It’s a big deal to me as well. My ‘fix’ is; I don’t use 2023.

It will be fixed at some point but there’s no saying how long it will take. A first update for 2023 was released a week ago so I guess it will take a few months before a next round of fixes is released…

@kevin58 he’s describing this bug in the second image in this post SU Outliner 2023 seems different - #9 by maxB

Hello Kevin (I wonder if we are of the same vintage).

Yes, SU 2023.

I have always welcomed the release of the new SU; I take seriously the implied promise of a subscription - ‘that the new version will be timely, and fit for purpose’. Not this year.

I think I’ll follow maxB’s lead and go back; SU 2022 is plenty good enough for me.

You don’t need to go back to 2022 from 2023 to get around the renaming of multiple selections in ‘Outliner’ and give up on other new features of 2023. Just go ahead and click each group you want to add to the multiple selection. When the names change to ‘Group’ don’t freak out just yet. Just hit Ctrl+Z and the original names return and they are all selected. Now do what you want with them.

That’s a useful work-around thanks Rob. But I will still be wanting the problem fixed asap; my brain is too rigid to always remember these new steps. Appreciated!

O wonder if the sketchup team is aware of this bug. I don’t know why but it affects only windows machines, on MacOS I can’t replicate this bug, I use both OS, but I’ve been using more my Mac since there is another bug on layout for windows, it crashes every time I try to add a keyboard shortcut on the preferences.

I do appreciate this suggestion but its not a workable procedure in a working environment. It would be a (hopefully) temporary confusion of my muscle memory and I rather stick to SU 2022 while the Trimble team is fixing this bug.

@colin Maybe you can you confirm the SketchUp team is aware of this issue? More info here - the bug in the second image in this post SU Outliner 2023 seems different - #9 by maxB

I’m kind of new here so I don’t know, but is there an official way to report bugs? Many software’s have one.

@Willo58 , I’d like to see it fixed as well. It’s funny how our brains work though. I primarily use 3ds Max, Photoshop, Ironcad, After Effects and SketchUp now. Somehow, when I’m in each one my brain adapts and I use shortcuts for each one even as they are all different. Adding this one workaround, while just more to think about, is not too bad, but it’s still disruptive. I wish I could create a shortcut key for ‘Rename.’ It is a pain to right click and have to go all the way to the bottom to click on ‘Rename.’

yes, it has been stated a few times already here and there, it likely has to do with the Qt framework change on the PC version this year.

the framework hasn’t been changed on macs yet.

yeah, ok, you’ve said it several times on several issues, but switching to PC or Mac everytime you get a bug is not a healthy solution.

you do realise the 5th and 8th messages in the thread you mentions are from colin right ? :wink:

I used to do that until somebody on here pointed out its much easier to have the Entity Info tray open, and just click in the ‘Instance’ box to rename the group.

Duh, that’s a great tip. Thanks.

I couldn’t find an exact bug report that says groups get renamed. I see the 23.0.1 release had three Outliner related fixes, including one to do with renaming not working properly.

I tried the steps you gave in the latest build I had, and didn’t see any problems. I reinstalled the version you have, and still don’t get the problem. First I shift-select three groups in the scene, where I have named the groups a, b, c, d, e, then I shift-click on d in Outliner, and it becomes selected as well. No renaming happens.

Any idea what I’m doing differently?

It’s only on windows, sketchup on MacOS doesn’t seem to have this bug.

Are the groups nested?
Version 23.0.419 (edited)

In my test (on Windows 10) I tried both nested and not nested. I will study your screen recording, and use the same names and structure you used.

Here’s my screen recording, also in 23.0.419 (I think you mistyped your version). See if you can tell what I am doing differently.

Weird isn’t it? I did notice some strange behavior while selecting inside Outliner, as if it wouldn’t response directly on my mouseclicks.

Region setting, maybe?

Is it possible that it is a bug in my PC?