The mouse shortcut doesn't work anymore

Hi,
When I have installed my Logitech mouse m705, the mouse shortcuts changed and on when clicking on the wheel mouse, it is no more the orbit tool… How can I fix it… I tried to go through the configuration of the mouse, but I can’t do anything…

Thanks

If there’s no option to change the settings in the driver, you should deinstall it and use the standard OS driver.

There is a special place in the afterlife for mice manufacturers who think mouse-specific software is a good idea. I agree with Cotty. Standard driver is best driver.

I fixed the same problem with my Microsoft 3 button mouse on Windows 8:

  1. hit “windows button”
  2. type “mouse”; click on the mouse settings icon next
  3. set wheel button to “middle click”.

I have a similar problem with my Logitech mouse. If I middle-click my mouse, the Sketchup (v15.1.106 x64) cursor changes to the orbit tool for a fraction of a second, but then immediately switches back to whatever tool I was previously using. However, I am (intentionally) using the default Microsoft mouse driver in Windows 8.1, so my computer has no option to reassign the middle mouse button. The mouse works fine in all other programs, where clicking my mouse wheel is correctly interpreted as a middle mouse click.

How do I get this to work with Sketchup so that a middle click will temporarily change to the orbit tool?

I figured out my problem - Sketchup was conflicting with a macro program called AutoHotkey. If I disable AutoHotkey, then the middle mouse button works as expected in Sketchup.

2 Likes

Thank you that solved the problem for me too :smile:

Hi, could you tell which mouse have you been using?
I’ve been thinking of buying Logitech M705 or M510, but I use the middle click a lot, and to me it seems that users have a lot of problems with middle click on these devices. How does yours mouse behave only with the Microsoft drivers? Is the smooth scrolling available then(if you have it)?

I too can no longer use the mouse shortcuts. They worked fine up until the final strokes of my last project but no longer. I do not have AutoHotkey installed so that is not it. I’m thinking I must have changed a setting inadvertently to modify the behavior but I don’t know what that could have been. Problem is, once you get used to the mouse shortcuts you are kind of lost without them.

Any suggestions would be most appreciated!
Thanks.

1 Like

Hi dcurtis,
I’m in the same boat as you. Did you ever find a solution to your problem?
Cheers,
Fred

Just wanted to share my fix I found on another board. My mouse was working perfectly fine a day ago, get to work and it doesn’t work, anyways, here’s the fix from another board: "Paul Russam
6/2/06

Other recipients: Pro_Use...@forum.sketchup.com

If its a logitech then the default fot the wheel is ‘auto scroll’ or something like that. You need to change the action to ‘Middle button’.
This can only be done in the logitech setpoint app, NOT in the mouse control panel that comes with Windows.

In setpoint:
Select the wheel
Change its action/function to 'Other’
Pick ‘Middle button’ from the list

Hope this helps
Edit:
Opps just re-read your post and noticed that its a MS mouse you have, the same problem/feature ocures in the intellepoint drivers, the wheel needs to be set to ‘middle button’

Paul
"

This fixed it immediately.