How can I get my mouse to Orbit


#1

Hi

I have a Logitech M705 wheel mouse. The training video "Get started with SketchUp - Part 1"


at 5:05mins, it tells me that (without clicking on the left hand menu icons) in addition to merely zooming by using the mouse’s wheel,by I can also get the mouse to:
A) do an Orbit (by “pressing the wheel down”)
B) do a Pan (by “pressing the wheel down and hold the shift key on your keyboard”)

However although the scroll wheel does cause zooming, I can’t get either A) or B) to work.

Any suggestions?


#2

Yes. Look at your mouse properties and check to see what the center mouse button assignment is. Typically when the Logitech software is installed the assignment gets screwed up. Better not to have the software installed because it isn’t needed.


#3

If you don’t want to uninstall the Logitech driver (the mouse will work just fine without it unless it is a model with some fancy extra buttons etc) seth the middle button command to “button3” in the settings - the default might be 4-way scrolling or something else unneeded.

Anssi


#4

I think I need my SetPoint software installed because I have a matching wireless keyboard.

The mouse wheel does ‘click’ in but all it does is make a zoom icon (magnifying glass with “+”) appear on the screen.


#5

I didn’t need it for mine but OK. Then fix the center mouse button assignment.


#6

“Middle button” should be the correct selection

Anssi


#7

OK - good point, Anssi. Thanks. OK I have ticked now ticked Middle Button for “3 Zoom” and… it works!

Many thanks :slight_smile:


#8

I’m having a similar problem and I’ve tried all the different settings without success. The mouse did orbit at one point but my drivers may have changed. I do have SetPoint installed and have found I need this in order to disable the touchpad. The Logitech mouse I’m using doesn’t show the same settings as depicted in this post. Here is what mine reflects. I’ve tried the middle mouse button but still no orbit/pan accelerators… Any suggestions would be appreciated. Thanks.


#9

I have no real idea. Middle button seems right place to start. Have you tried applying zoom? And then possibly re-applying Middle button? On the column of icons on the left, on the 4th icon from the top I do NOT have Enable application-specific button settings ticked.

Btw, mine is working OK but is still VERY clunky!


#10

Thanks for the suggestions. I have toggled back and forth, trying all the different possible relevant options but still no luck. The “Enable application-specific button settings” option is toggled on by default but if nothing is actually configured I assuming it doesn’t serve any purpose. I did try adding “Sketchup Application” but it says you cannot do anything to the middle mouse button so it didn’t work in my situation.


#11

Do you really need functions from the logitech driver? Otherwise you can deinstall it and use the native (working) OS drivers.


#12

I could do that if it worked, but I couldn’t figure out how to disable the touchpad without the Logitech driver. Having the touchpad enabled along with the mouse is problematic for me because I inadvertently swipe the touchpad while typing which changed cursor location. So the SetPoint app sees the wireless mouse “when present” and disables the touchpad. The other thing is, the MMB orbit/panning worked just fine WITH the Logitech driver at one point but somehow something changed.


#13

So I uninstalled the SetPoint driver and can still disable the touchpad with the Dell Touchpad software. But there is no difference in behavior. Still no Orbit/panning with the MMB in Sketchup. Any more suggestions would be very much appreciated! I’ve actually been putting off a new project just because I’ve been Sketchup-without for some time. Can’t live without it.


#14

Have you tried a different mouse to see if it’s a problem of the specific mouse?


#15

Yes, others have the same problem (no orbit) so it don’t seem hardware related. The mouse I’m using worked fine before so I don’t see why it shouldn’t continue to work.


#16

Hi. This post is to share my experience in case it helps someone.

Mouse orbit stopped working for me some months ago, and I didn’t find a solution. I checked the middle button, etc. and all was correct. My mouse was a wireless Logitech M317.

Then my computer died and everything had to be reinstalled, including Sketchup 2017. Mouse orbit worked for a month or two and then stopped working again.

Recently I bought a new Logitech M317c mouse. Tonight, I decided to start using it and, lo and behold, mouse orbit started working immediately!

This was a relief as it is very useful. The previous mouse seemed to be working fine in all other apps, just mouse orbit in Sketchup wasn’t working.

So I don’t know exactly what the problem was with the old mouse, but using a new mouse seems to have solved it.


#17

Your experience follows my law, Martin’s Law.

Everything that stops working was working fine before it stopped working! :slight_smile: