Reprogram middle mouse button

When I press the middle mouse button on my Logitech Model M187 mouse it displays dashboard. How can I reprogram it to allow me to use another sketchup function?

That is controlled by the Logitech software. Take a look in there to set it to Middle Button (that is the value you will want in order to use the scroll wheel to orbit in SketchUp).

1 Like

I have tried all the middle button options but still unable to orbit when I press the middle button. I assume I select the “gesture” option but have tried all the suboptions but none work. Any suggestions?

It’s strange that you are having a problem with this. I use a Logitech mouse on my MacBook Pro. Just plugged in the receiver and everything worked as expected.

I don’t have access to my MacBook at the moment but can you turn off gestures for SketchUp only? You don’t really need gestures to work in SketchUp anyway.

I restored the mouse to default settings. Now when I press the center button I am sent to the “Dashboard”. Not sure what to do next?

Go to the very basic mouse settings and set the scroll wheel click to middle mouse button.

2 Likes

OK I did that but no luck. It only orbits when I have orbit selected.

Here’s my Logitech software:


See where it says Middle Button when I hover over the scroll wheel? What does your’s look like?

Here’s mine:

What shows up when you hover over the middle button circle?

Is that a control panel for a Logitech mouse? It doesn’t look like their logo to me.

FWIW, I never installed any software for my Logitech mouse on my Mac. What if you uninstall that software from yours?

logi is the new brand for their software. Rebranded, but basically the same software as ever…

TheOnlyAaron http://forums.sketchup.com/u/theonlyaaron SketchUp Team Member
August 30
What shows up when you hover over the middle button circle?

Visit Topic http://forums.sketchup.com/t/reprogram-middle-mouse-button/50713/10 or reply to this email to respond.

To unsubscribe from these emails, click here http://forums.sketchup.com/email/unsubscribe/0b6570c97d33aafbcb5ee8da901abb7069fbb7c3db81d2a471f18f40b36a41c6.

So, what happens when you set that to Middle Button?

EDIT - (Did I finally beat @DaveR on a post?)

1 Like

I set it to “click” to no avail

Did you select Middle Button at the top of the list?

I selected the “Middle Button” at top and it sends me back to “Dashboard” when clicked.

Usually the simplest fix is to remove the the logitec software and just let the normal muse drivers do their thing.

1 Like

How about removing the Logitech software altogether and rebooting the computer? As I said, I never installed any Logitech software on my Mac. I just plugged in the receiver and it worked as expected.

How do I remove the logitech mouse driver?