Mouse middle button behaviour

I am using a Logitech MX Anywhere mouse, I have Logitech Setpoint and have checked that the Middle button is set to the middle button. I have added Sketchup to the application list but the middle button says it is not available to the application.

I can toggle between Orbit & Pan if I use the shift key with the mouse middle button, is that the intended behaviour?

Thank you… liz

Pressing the middle mouse button should activate Orbit. Pressing Shift with the middle mouse button should activate Pan. You can go back and forth between the two tools by holding or releasing Shift.

You can see the change from Orbit to Pan as I hold or don’t hold Shift.

That is what I thought should happen. What actually happens is that pressing the middle button makes the picture ‘jump’ a little, it does not activate Orbit.
If I manually select Orbit, either using a button, menu or ‘O’ I can use the mouse to do the orbiting and Shift to pan.

So I can’t work out what might be stopping the application controlling the middle button and why Setpoint indicates it cannot be used by applications.

Any ideas? Thank you… liz

It usually works if you use the standard mouse drivers rather than the logitech ones. Try removing them.

Do you press the middle mouse button or just click it?

Lis, both @Box and @eneroth3 have good points.

Orbit should be active only as long as you hold the center mouse button down.

I’ve got Logitech mice on the four different computers on which I use SketchUp. They were all just used as plug and play. The Set Point drivers aren’t installed. You might try uninstalling it if Julia didn’t hit on the issue.

before removing I would try to update to the latest Logitech SetPoint version and reset the mouse key settings to the defaults.


Hi Dave,

Thanks for helping.

[I fear should have said that I was using a 2016 install package because the 2017 installation kept failing. However the PC is now up to date with all Windows updates (there were over 200 outstanding as it had not been used for a while!) So I thought I would try installing 2017 again. Now the problem has gone, hooray!

I have no idea what was happening but since it is now cured I don’t care!

Thank you…liz

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.