Textures appearing as solid colours all of a sudden


I’m using Sketchup 2019 on Windows.
I’m working in an existing model with textures already applied, and all of a sudden (for no obvious reason) all textures are showing only as a solid colour. I have checked the scale of the model vs the texture which is correct, and the face style is set to shaded with textures. Any ideas?!

Thank you in advance :slight_smile:

Can you share the .skp file so we can see what you’ve got?

The upload keeps failing, is there a size limit?

Yes. I forget what the limit is. Use Drop Box or Google Drive and share the link.

It used to be 3mb but then it changed to somewhere around 10mb, but recently I have seen some in the teens, so it’s a flexible 10mb.

1 Like

Good to know.

You need to allow access.

I think I’ve done that now - has it worked?

Yes. It’s downloading now.

I see textures in your model although they drop out while zooming or orbiting which is normal behavior when the graphics card isn’t able to keep up with rendering the model as the camera changes. If you aren’t seeing textures even when the camera isn’t being moved, I’d suspect your graphics card is just overworked.

I noticed a couple of other things about your model (besides the huge file size)
Layers are being used incorrectly. ALL edges and faces should have Layer 0 assigned to them and Layer 0 (Untagged in SU2020) should be left as active at all times.
Screenshot - 11_10_2020 , 5_27_15 AM

It would be a good idea to purge unused stuff from the model once in awhile. Go to window>Model Info>Statistics and click the Purge Unused button.
Screenshot - 11_10_2020 , 5_29_16 AM

It would be a good idea to correct the face orientation as you go. there should be no exposed blue back faces.

And it would be a good idea to get rid of excess stuff in the model space. If you don’t need those lines off to the right or the furniture to the left, delete it.

FWIW, I’m running Thom Thom’s CleanUp3 on your model. It’s been running for 15 minutes and says it has 42 hours to go. We’ll see how long it actually takes. This kind of thing stems from using obese components from the 3D Warehouse without first cleaning them up. Now more than 53 hours remaining.

In addition to @DaveR’s valuable points I wonder if what’s changed might be that you accidentally clicked to set the Face style to Shaded, instead of Shaded with Textures?

Although it’s quite hard to do that by accident! I have a toolbar which includes X-ray, Back Edges, Wireframe, Hidden line, Shaded, Shaded with Textures, and Monochrome, but otherwise it’s a menu selection.

Deleting the spare furniture, then Purging the model almost halves the file size to around 201MB.

Maybe as Dave says, it’s more likely you’ve just grown the model to the point where your graphics card can’t cope with the textures any more.

Sorry, I’ve had a spinning blue wheel since I saved to send you - would backup the overworked theory! I wasn’t seeing the textures at all so I assume the only way to fix this is to clean up the model?

I don’t know a great deal about the layers or how to use them - how do I assign edges and faces?
Sorry, I’m not familiar with face orientation?
The components all come directly from our furniture suppliers so I guess I’ve wrongly assumed they’d be safe to use - how do I go about cleaning them up. - Apologies, I know my knowledge is lacking, I’ve been thrown in at the deep end with working from home.

Thank you very much for looking at this for me, I really appreciate the help

1 Like

She did say that she checked that Shade with Textures is enabled.

I should have seen that - sorry.

Cleanup might help to reduce the file size to where the textures will be displayed by your graphics card.

Layers (now called Tags in SU2020) are to be assigned to groups and components. The correct work flow is to leave Layer 0 (Untagged) active at all times. Model an object, create a component or group to contain the geometry and then assign a layer (tag) to the component/group. Leave the Layer 0 assigned to the geometry. To fix your model, I used a plugin from TIG called Default Layer Geometry.

Faces in SketchUp have fronts and backs. The back sides are identified by the blue color while the fronts are white. It’s best practice to keep front faces exposed. There a few different reasons for that. One of them comes into play if you run the model through a rendering program. Many renderers won’t render back faces even if they have materials applied to them.

Unfortunately many furniture suppliers as well as appliance and plumbing fixture suppliers use automated means to generate SketchUp components of their products starting from other files. This can make nice looking components but they tend to be overly detailed when used as entourage in larger models. I’ve seen kitchen appliance components like gas ranges and refrigerators that have all the plumbing parts and other details that won’t be seen when the thing is used in a kitchen design.

The general wisdom is to always open components you get from other sources in a separate file and strip out the unneeded stuff. Remove the racks, drawers, and the light bulb from inside the refrigerator along with the compressor and the heat exchanger. Leave only what will show. Then insert the component into your project model.

No need to apologize. It seems to be a fairly common thing. I’ve worked with a number of folks who seem to be in the same boat. Or rather they’ve been thrown out of the boat a long way from shore. It’s not easy to learn to swim when you’re in the middle of a cross-Channel race.

Thank you, that’s all really great advice.
Probably a silly question about faces…how do I ensure the front face is exposed? The floor in my model for example which was showing as blue, I drew the shape from above and that’s how it appeared - how would I correct that?

You can right click on a face and choose Reverse Faces to correct it.

When you first draw a shape on the ground plane, the back face will be up. Since SketchUp is a 3D modeler, it expects your next step will be to extrude that shape to make it 3D. In effect you are looking at the inside of what will become the bottom face of the 3D volume.

I would suggest that you draw the outer perimeter of the building and give that some thickness before you outline the walls and pull them up. This will give you the correct face orientation from the beginning. It may make sense to create the floor and group that geometry separately from the walls. Then you create a group of the walls and give them a “Walls” layer/tag. That way you can turn off the wall visibility if needed to make it easier to work on the stuff inside. This is especially helpful with small rooms.

Makes sense, thank you.
Purging the model has brought the textures back, so one problem solved!
And I now know the painful slowness is my dodgy work flow! I’ve downloaded Default Layer Geometry out of curiosity but nothing seems to be happening - should there be more to it than just selecting it from the extensions drop down?

Excellent! So purging unused got rid of enough stuff to get your graphics card playing along better.

You might try closing SketchUp and restarting it to make sure the plugin is loaded. Then when you select it in the menu, you should get a popup window that looks like this:
Screenshot - 11_10_2020 , 7_59_24 AM

Click Yes and it should run. when it finishes it should give you a report similar to what I showed earlier.