Textured faces are flaring on the edges; some faces are transparent and not selectable

On a recent file the 3d faces with textures added, are presenting with flared edges when I zoom in closer the problem is even worse. Some surfaces are simply not being recognised when selected, transparent both visually and when trying to select the face to modify. Older files are 100% OK and don’t display any of these same problems when I open them up to check. the “field of view” is not performing as normal; when I change the FOV the model zooms way out nd the image plain is much further away from the model then it usually is; impossible to move inside the model without loosing everything from the view. System often crashes when I change between different "perspective’ settings.
Have none of these problems on other files. Any clues please?

My guess would be the model is a long way from the origin.
Best option is to attach your file so someone can check.

Its the same file that works OK in previous revision (just did a “save as” to create the next version) and the origin is the same in both (and many other versions of this file model); the other files are all OK. Have checked the file size and it’s using much the same level of memory to generate according to the “Task Manager” data.

Tried attaching the file with an *.skp file extension and this site came back with a “file type not supported”.

My mistake, it was an *.skb that was not accepted to upload. Just tried the *.skp file and that failed to upload…guessing the file size was too large.

Your screenshot only really tells us that it is probably a graphic issue, it could be the graphic driver for your card or something in the model, or something else.
I would update your graphic card and purge the model.
You can also use dropbox or similar to attach a link to your model.

You might also try changing Material Transparency to Nicer from Faster.

Thanks for the ideas; I’ll look up how to purge the model.
The graphics card works OK on other models, it’s just this file.

Window/Model Info/Statistics Purge Button.

Thank you. Nothing came up through “help” site when I typed in “purge model”…but then again it;s never that simple. Appreciate the info!

hello, switch to perspective view instead of parallel (camera menu > perspective)

Thanks Paul, have tried all three perspective options (many times!!)
Have just closed and reopened the file after purging and the model has corrected itself back to normal.
Thanks guys.

That’s the back face color bleeding through. Common graphics card/OpenGL thing. As Box indicates it can be worse if the model is located at a great distance from the origin. You can reduce the appearance of it by editing the style to make the back face color dark gray.

Here’s a quick example. I set the back face color to magenta to make it easier to see. You’ll need to expand the images to see the difference.

And after editing the back face color to make it dark gray.

Thanks for the tip Dave; certainly helps with certain textures but unfortunately the model holds many different textures which means the ‘trick’ works for some and not others, depending on which tones you wish to improve.
Which graphics card would you recommend for these larger files; running a basic HP PC using? Current card details - see screen shot below. Screenshot (26)