Texture Scaling

I’m probably missing something obvious…;.

I want to apply a wood texture to faces of something I’m designing. I have a nice jpg of the birch plywood texture I want. I create a texture and “paint” it on to the faces. But, the scale of the grain is wrong.

I found texture->position and have the 4 pins at the corners of the texture. The blue, bottom left appears to be for scaling the texture. But it seems to scale only in one direction. Dragging off the scale axis rotates the grain instead of stretching it that direction.

Do I need to scale the .jpg instead?

Use the green Rotate pin but move it in or out if you want to resize the texture.

My preference for creating materials is to draw a rectangle in the model space that is the correct size. Then use File>Import to import the material and apply it directly to that rectangle. This will set the size correctly from the beginning. So if I have an image of an 8’ long board, I draw a rectangle that is 8’ long.

Here I have a plywood texture that is supposed to be 36 in. wide. The length takes care of itself so I don’t worry about the other dimension of the rectangle.

1 Like

Now, I can not seem to get the Texture menuitem to come up when I right click on a selected face. I’ll keep struggling with that, meanwhile:

Well, that’s what I’ve done, and the text is not the correct size. Somewhere, the texture in the jpg has to be scaled to be consistent with the 8’ board, right?

Is the selected “face” more than one? Or is the texture applied to the group or component instead of the face? The Texture menu shows up only if you have the material applied to a face and are only right clicking on a single face.

I think you’ve missed something.

Here’s the dimensions of the texture after I imported it for the GIF above.

You can also edit the dimensions in the Materials panel if you want. I just prefer to skip that part.

No. There’s no need to do that. When I do my textures I know the length of the part of the board I’m using but that info doesn’t come into play until I get into SketchUp.

1 Like

I found your reply about having multiple faces selected when trying to apply the texture. I have only one face selected, but that face is in a component that is instanced twice in the model. I see the face (and only that face) highlighted in both instances.

But, I still can’t get the texture menu-item to come up. I know it’s not because it’s a component, because I was earlier having no issue bringing up the texture menu.

Yes, I’m definitely missing something. Is your 8’ board in the .jpg/gif? If so, that makes sense I thought you were saying you applied it to an 8’ board in your SU model.

Share the .skp file so I can see what you’ve got.

1 Like

That will take a bit–I can’t send the entire file due to license issue. But I’ll pare it down, hopefully the issue doesn’t go away when I do that.
.

So, I can paint the texture on the face, no issue. The immediately right click (after the texture is applied). No texture menuitem.

Thanks!

Upload it to Drop Box and share the link via a PM. I won’t share it with anyone else.

1 Like

It appears you’ve removed the texture from the box and when I opened the file the face style was set to Shaded not Shaded with Texture. If textures aren’t actually being displayed, Texture won’t show in the context menu because there’s no way for you to see what you are adjusting.

With the information that you’ve got the model scaled up by 1000x is new and would have been helpful to know earlier. Since you have the model scaled up so large, and the texture is so small, it’s clearly not going to appear as the texture when you apply it. Why don’t you change the units to meters (as I’ve done below) and then edit the material size from 100mm square to 100meters square?

FWIW, although you delete the components from the model space you didn’t actually purge them from the file so they are all still present. If you don’t want the world to get the file you should remove it from your earlier post.

1 Like

Texture still does not show up for me.

When I choose “Make Texture Unique”, I get the option to “select texture size”. That’s the option I need, but I don’t think it was presented under anything under texture.

But, using the texture size should work–since it has a maximum pixel size constraint, I’ll need to scale it down first.

I can work with that. Or, probably easier to just scale the jpeg and apply texture at real world scale.

Do you have the face style set to Shaded or Shaded with Textures? I wish you’d just share the model with the texture applied so I can see it the way you are.

Why are you doing that? There’s no need for that here.

If you are going to scale the model back down, don’t apply the textures to the scaled up version of it. You’ll just make more work for yourself.

Apply the texture after the model is at real world size. Make sure that you scale the component definitions when you are scaling the model down to real world dimensions.

1 Like

I have it set to shaded with textures. I did purge this time, please let me know if I left unused items.

texture issue|690x194

Why are you doing that? There’s no need for that here.

Understood. Only because there is no Texture menuitem presented. Just “make texture unique”. See the attached screen shot. Only that one face is highlighted.

If you are going to scale the model back down, don’t apply the textures to the scaled up version of it. You’ll just make more work for yourself.

Apply the texture after the model is at real world size. Make sure that you scale the component definitions when you are scaling the model down to real world dimensions.

Makes sense–again, requires I first scale the jpeg.

Ok, texture doesn’t show up until you have actually applied a texture.

I went back to your earlier post–I didn’t see the gif first time. Sorry I missed that.

Not in the file you uploaded. It was set to Shaded.


It need to be set to Shaded with Textures.

Well, of course!

Your purge didn’t get rid of unused components.

1 Like

On the first upload, it was set to shaded, not shaded with textures. Yes, that what confused me.

Not sure what happened with the second upload. The file is still on my system with the shaded with textures option on, and I haven’t done another save. But, I downloaded from the line in this post and agree it’s still set with shaded, not shaded with textures.

I should have used another name for the second upload, but I can’t find another copy that I might have uploaded by mistake. Maybe the original got cached somewhere.

I’m not sure I’d say “Well, of course” to the Texture option not being presented, while “Make Texture Unique” is presented. But, anyway, I’m good now, and thanks for all your help.

The context menu is context sensitive. If there’s no texture applied to the face there is no reason for that menu item to be displayed.

So, if there’s no texture applied to the face, why is there an option to “make texture unique”

Because the default material could be used to create a new material. But like other plain colors, you can’t change the scale or or orientation. If you apply a color to a face you won’t get the Texture option either.

So, first you must apply some arbitrary texture to each face then change to the texture you really want (so you can scale it)?

So, looks like once in the model, you can use it (scaled) by simply painting it on.