Texture Images All of a Sudden Come in Very Small

I created a custom texture image in Illustrator and exported it as a jpeg. I importethe new texture just like I always do, but when I go to apply the texture it’s so small that it looks like a solid color. And when I scale up the texture it’s so distorted I can’t even use it. This is just happened all of a sudden. I had been creating custom textures and importing them several times that day without any scaling issues. I was, however, having problems with the images coming in compressed or stretched causing me to have to stretch the image back to it’s original proportions.

1] Original texture artwork
2] What it looks like when I first apply the texture
3] What it looks like after scaling the texture

Please help!

How are you inserting the texture in the first place? How large of an area is it supposed to cover?

What are the dimensions of the model? Maybe you could share the SKP file.

Is there another way to share the SKP file. It’s 5MB which is too big to upload.

First thing is go to Model Info>Statistics and click Purge unused. See if that reduces the file size enough. Otherwise upload to Drop Box and share the link.

Thanks. See attached.

Models.skp (2.1 MB)

How big is the material supposed to be?

12’ wide to fit the widest face of my ATM.

I see a couple of major problems in your model. First, you scaled the component down but never used Scale Definition to correct the component’s scale. The groups inside have been scaled down, too. This will cause the material to show incorrectly. You’ve also applied a different texture to the group inside the component which you shouldn’t have done.

Here I’ve fixed the scaling problems you created and reapplied the texture to the faces.

This is not a bug in SketchUp. You would avoid this problem by drawing the model at the correct size to begin with.

Here it is at 12’ wide.

If you import the image using File>Import and apply it to a rectangle that is the size the texture should be, it’ll automatically scale to the correct size.

I’m not sure what I did wrong. My model shows the face at 12’ wide which is correct. I’m so confused.
I feel we should start from the beginning so I can understand where I went wrong and how to avoid it from now on.

I started my model by importing a DWG file of the profile of my model. And of course it doesn’t import at full scale. So after I connect all my lines so they have faces, I them scale everything up, which I’ve learned isn’t a perfect science since the scale tool seems to snap to hidden guides. From there I start pushing my objects. Is this where I’m going wrong?

Right click on the component. You’ll see that Reset Scale and Scale Definition are available to use. This indicates you scaled the component after creating it.


First, you should be able to have the imported DWG come in at the correct scale. You need to set the correct units under Options in the Import window. Then you shouldn’t need to scale anything.

If you choose to scale after importing the DWG, open the component for editing, select all of the geometry and scale that. Opening the component and scaling the geometry will correct the component definition’s dimensions automatically.

Resizing doesn’t have to be a black art. One way to resize,scale accurately is to use the Tape Measure tool. Measure a know length in the model making sure you click at each end. Then type the actual dimension and hit Enter. If you need to do this with the imported DWG, do it with the component open for editing.

Can you share the DWG?

Man, this is some great information. I’ve tried searching the community for this type of info with little to no success.

Attached is the DWG file.
Outlines_OptA.dwg (8.1 KB)

How tall is this thing supposed to be?

I’m glad that info was useful.

Another question I have is when you say component, are referring to the texture image?

Also, is there a way to import a png logo with a transparent background and apply that to a color filled face? I think in the past when I apply this type of image the face ends up being transparent as well.

14’-5" Tall.

The DWG is not full scale. I’m not used to making my outlines full scale because a lot of the times it’s too large for Illustrator’s workspace. Plus I never knew how to adjust the scale when importing to SU, until now.

No. A component is a sort of container with a collection of entities in it. When you import the DWG file, it comes in as edges in a component.

You can import the image as an image instead of a texture and lay it over the textured face. In many cases it might make more sense to create a custom texture with the logo included.

For something this simple, is there a reason you aren’t just starting in SketchUp?

Scaling with the Tape Measure tool. Since you aren’t making the DWG to a specific scale, resizing after importing will be required. Notice the component is opened for editing before resizing.

No. I guess I’m just used to starting my drawings this way. Plus it seems faster than toggling between programs to check dimensions, measuring, then drawing. If I import, all I have to do is explode and connect 2 lines within a shape. I’m open to suggestions on the best way to do this moving forward. I want to improve my workflow and better understand good SU practices.

Sweet! That’s what I’ve been missing.