Brick texture not at correct scale when applied inside components


#1

I created a custom texture (a brick wall) based on jpeg, and it paints at the correct scale when applied to a surface that is not part of a group or component. However, when I apply it to a surfaces that is part of component, where I have to edit the component to paint the surface, the bricks are scaled down and appear a lot smaller. The only way I could find to correct this was to go back, right click on the surface, and select “Make Unique Texture”. Although that fixed the scaling problem (the bricks are now the right size), it also added some white “spider web” lines that radiate from certain corners. Not sure why or how to get rid of those. So I’m hoping there’s a better way to do this. I’m new to SU and still trying to find my way around… Thanks for any help!


#2

Did you scale the wall component before applying the material?

As a test, draw a new wall of the proper size and make it a component. Then open it for editing and apply the texture. Does it work correctly?

How did you import the brick texture in the first place to get it sized properly? What size does the Materials editor show it to be?

Sharing the SKP file with the wall and texture would go a long way toward getting you a really solid answer to your question.


#3

The model I’m working with (of a house) was actually created in another
application (Solid Edge) and imported into SU. I did this because it’s
a lot easier to apply colors and textures with SU than SE. Nothing was
scaled after importing, although I did explode it one level to make it
easier to access the surfaces for painting/texturing. The brick texture
I’m using was created in SU based on picture I took of a wall (cropped
to 33"W and 26"H). Some textures were applied in SE, but my plan is to
replace all those with ones created in SU once I sort of know what I’m
doing.

I’ve include a link to the model (below) so you can take a look. As I
mentioned, I’m new to SU so any suggestions are welcomed. My goal is to
use SU to examine different siding, trim, and door colors for a
remodeling project (the brick will stay the same).

Thanks again for the help.

I’ve linked 1 file to this email:
HardieLap1_R2.skp https://db.tt/J9XqlsEQ(42.5 MB)Dropbox
https://www.dropbox.com/https://db.tt/J9XqlsEQ
Mozilla Thunderbird http://www.getthunderbird.com makes it easy to
share large files over email.


#4

The end wall is scaled down from it’s original size - I suspect 2.54 - inch/metric conflict.
Select it and look in the Context-menu to see the Reset Scale option is available - which indicates this.
How did you import it ?
What was the original CAD file’s units ?
What Options did you choose for the import units ?

If it were unScaled then the material would apply properly.

The import has triangulated faces [hidden lines visible when switched ON in View…]
When you ‘baked’ the textures for those triangles the texture image does not perfectly follow the sides and you get white-bleeding… hence the spider web look now indelibly baked into the model.

The way I’d do it is to import it at into a new file at the correct size [i.e. no scaling].
Trying to fix it afterwards is too much of a pain.
Then Edit the various wall parts in turn, and use a Plugin like thomthom’s CleanUp to remove the selected coplanar edges which are unnecessarily triangulating those faces.
Then apply the brick textured material to the wall faces as desired.
Select a face and use the Context-menu > Texture to position the brick texture so that it looks properly set up on that face - you can eyedropper sample a suitably positioned material off one face for use onto another, so you don’t need to ‘fix’ every face…


#5

Solid Edge doesn’t natively export to .skp, so I used a third party
application (SimLab) to do the conversion. The model was created in
inch units, but the SU template may have been metric. I think I’ll take
your advice and try this again, but maybe clean up a few things in the
model first (like remove all the colors and textures currently
applied). As far as getting consistent units, is there a particular
template you could recommend, or should I try to create my own? I
couldn’t find where to set units SU, but I’m sure it’s right under my
nose! Thanks for help.


#6

Units are set under Window>Model Info>Units.

You can make your own template with the appropriate units. Open a fresh SketchUp session, change the units and use File>save as Template to save it making sure Use as Default is selected if you want to use the template each time you start a new session.


#7

Your current model’s actual Units shouldn’t matter.
A SketchUp model is always stored in inches.
When you are using Model Info > Units of ‘mm’ it’s actually an ‘overlay’ for your convenience, BUT the data is always saved in inches inside the model’s SKP database.

So when you converted your SE data into SKP data it ought to be full-size and in inches.
So maybe the SimLab settings are adrift or the SE units are not what you assumed they were?
The scaling down of the groups etc by ~1/2.54 suggests some metric/imperial confusion.
The SKP you import into your model should need NO scaling at all, since in it 1" should be 1" not ~2.54".
Did you actually scale the incoming SKP file, or did SimLab do something weird with its contents ?


#8

I did no scaling (at least not intentionally). But if you look at the
size of the house, it’s correct. For example, using the tape measure
tool the porch posts measure 2.17m (about 85in) which is correct. So
the only place I’m seeing this scaling is with the texture. Tomorrow
I’ll try importing a cleaned up version of the model (into a template
with imperial units) and see how that does. Hopefully things will
behave better. Thanks again for the feedback.


#9

If you select say the end wall [component-instance or group?] and use the Context-menu, it says Reset Scale…
If you choose that option, then the wall grows to be ~2.54 times bigger, showing that it has been scaled at some stage to be smaller than it was originally made - a metric/imperial units ratio of some kind.

If you bring the external SKP in to the model’s SKP and use the Tapemeasure tool to pick two points a known distance apart,
If the Measurement box does not show the same value type it in and answer Yes to rescaling the model.
Now all of the model is the correct size BUT groups etc will have been Scaled.
This looks like your issue.
Exploding the parts removes their scaling, but with many such parts it’s time consuming !


#10

You can also right click and choose scale definition. That should fix the size issue.


#11

[quote=“tahota1, post:10, topic:15866, full:true”]
You can also right click and choose scale definition. That should fix the size issue.
[/quote] That context-menu option only appears if it’s a component-instance - so if it’s initially a group you will first need to convert it into a component.