Creating custom texture from skp model

textures

#1

I have created a skp model that I have saved as a jpeg image to use as a texture. The problem is that when I import the image as a texture, the resolution is very poor compared to the original model. First I tried exporting a 2D image from SU. I did get a jpeg from that, but when I tried importing that as a texture I got a circle/slash no-go symbol. So I ended up snipping the image to save as a jpeg. I have uploaded a file with the original SU model on the left and my imported texture on the right. When you zoom in you can see how bad the resolution is.


#2

add the skp file…

john


#3

If the file you saved has the extension .jpeg, you won’t be able to import it. If the extension is .jpg, you will. You would get the circle with the slash if you are trying to import the image as a texture but you aren’t applying it to a face.

I would export as a PNG at a fairly large size and use the file type for import, too. PNGs don’t have the losses associated with JPG files.


#4

I tried again using both PNG and TIF formats with better, but not perfect results. I thought I had uploaded a file with my original post, but I don’t see it. I have tried again. In this example, my original skp is on the left, followed by the TIF then the PNG texture versions. Zooming in stills shows the texture resolution to be inferior to the original skp. Is this the best I can do? I didn’t see a way to adjust the file size when exporting from SU (only a choice of formats). To upload I selected the upload icon, chose the file and hit “upload”–shouldn’t take more than that, right?


#5

Maybe the file is too big. How about uploading the files to DropBox and sharing the link?


#6

perhaps (but not sure) in “preferences” you may need to select “use maximum texture size” for the model so that the on screen model has max resolution and then when you export, there should be an “options” button next to “save” in the windows screen, If you select options it will give you optional pixel dimensions to set for the export or will just use image size on the screen.


#7

Textures you import are resized to fit into 1024 x 1024 pixels if they are larger than that. You can grow this to 2048 or 4096 pixels if you tick the “Use maximum texture size” in the Window menu>Preferences>OpenGL dialog box.


#8

here’s the dropbox link for the file. On the left is my skp model, followed by the TIF and PNG texture versions. Thanks!


#9

Yours above. My rendition below. Is mine of acceptable resolution?


Before importing the image as a texture, go to Window>Preferences>OpenGL and select Use Maximum Texture Size.


#10

Sweet! That should work well. Thank you so much for your assistance.


#11

So for future reference, after selecting the model on the left and zooming to selection, I exported a PNG at 4000 pixels wide. I cropped the image tight and saved it.


#12

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.